Sign in to follow this  
lexi 95

95 Es300 A/c Doesnt Stay Cold...

Recommended Posts

lexi95,

Chances are that you are down on refrigerant due to a leak in the system somewhere. Its fairly easy to diagnose and may be fairly cheap to correct, providing your compressor or the cooling radiator inside the heater box aren't where the leak is. Most good garages can do the diagnosis for you. Good Luck!

Share this post


Link to post
Share on other sites

The expansion valve is probably sticking. This is a very common problem on the mid-90's ES models. It has been discussed numerous times on this forum. Do a search, entering "expansion valve."

Share this post


Link to post
Share on other sites

CUMan is right. It's your expansion valve. I drive a 94 es300 and mine did the same a few summers ago and I thought it was the refrigerant getting low but my valve was sticking. If a/c is important to you then better get it fixed before summer starts. Cost me around $500.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this