Sign in to follow this  
meitetsu

Rx300 Blowing 7.5 Amp Fuse (Position 44 On Fuse Block)

Recommended Posts

I just purchased a RX300 that keeps blowing 7.5 amp Fuse (position 44 on fuse block).

This is fuse for Radio and HVAC Control button lights as well as the shift selector.

As soon as you replace fuse and turn IG ON it blows immediately.

I see on the internet that several people have had this problem, but never see anyone post any solutions.

I'm sure it's probably a short but not sure exactly where.

Anyone ever had this problem and found the solution?

I appreciate any help.

Thanks.

Share this post


Link to post
Share on other sites

I just purchased a RX300 that keeps blowing 7.5 amp Fuse (position 44 on fuse block).

This is fuse for Radio and HVAC Control button lights as well as the shift selector.

As soon as you replace fuse and turn IG ON it blows immediately.

I see on the internet that several people have had this problem, but never see anyone post any solutions.

I'm sure it's probably a short but not sure exactly where.

Anyone ever had this problem and found the solution?

I appreciate any help.

Thanks.

It wasn't exactly clear whether the fuse was for the lights in all 3 mentioned things or for the radio, HVAC control lights and shift selector. Please clarify.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this