Sign in to follow this  
Mike Floutier

Obd-Ll Code P1305 - Ignition Coil No. 2

Recommended Posts

Hi guys,

My Ls430 has just done 250,000 miles so I decided to change my spark plugs which as you know involves removing the coil packs.

A day or two later I get a P1305 obd-ll code which relates to the no.2 igniter coil along with a "mis-firing" feel - no other codes.

This fault would appear after the car had warmed up and continue. However, after stopping the engine for 5 - 10 minutes the fault would disappear when I restarted BUT reappear after 10 -15 minutes etc etc.

I tried swapping the coil with one from the other bank but no joy - same problem, same circuit, no. 2

Does anyone have any suggestions?

I guess I simply have to test the continuity on the wires from the igniter coil plug to the engine ECU and the power and ground connections.

I did previously (100,000 miles ago) have a similar problem with this coil but it was solved by spraying the plug with electric switch cleaner and re-fitting it.

Could it be that the plug's connections have become so corroded that they are only making an intermittent connection. If so, is there a good way of cleaning them or if not can I get a new plug rather than the whole new loom.

Any ideas welcomed.

Kind regards,

Mike

Just to update this. I have been checking the ignition wiring and most items seem ok, ie. there is power where there should be power. There is continuity.... The only one that wasn't as I expected was the No. 2 pin on the Coil plug - the one that connects to pin 2 on coil 8 and thence to IF2R at the engine ECU.

Having disconnected the ECU plug this section checked ok for continuity but for shorts it was another matter. Measured from the ECU end there was no shorting at all BUT from the Coil plug there was around 2k ohms. However, this was the same for two other Coil plugs so I didn't consider this significant.

Not sure where to go from here???

Edited by Mike Floutier

Share this post


Link to post
Share on other sites

As mentioned on my mis-fire thread this was solved by cleaning the coil's connector plug (female) sockets.

Beats having to change the coil.

Mike

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this