Sign in to follow this  
MEDO

Slow Warming Up (About 20 Min.)

Recommended Posts

Dears

My Lexus LS400-1990 is very slow warming-up. The cooling fan is start immediately with starting engine. And fuel consumption is abnormal (too much). Also the RPM is about 1600 until warming.

Is that normal?

What is the reason?

Share this post


Link to post
Share on other sites

stuck thermastat, in the wide open position.

Share this post


Link to post
Share on other sites

Indeed, I was have the same problem (slow warm up) Need more than 20 minutes .. I tried to put piece of cardboard in front of radiator to minimize air quantity blowing by main mechanical fan .. Also I checked the Thermostat, by put it in a boiling water, (its opened with no problem..and its closed when put it in cold water). But I observed a very small piece of the rubber ring is broken, and when Thermostat closed at cold state, its remaining to leaks some water through the closed gate, just I removed all that rubber ring and that makes the gate closing completely .. Then I return it back in its hose .. Its work ... Now I need about 6 minutes only to warm up to the normal state and return the RPM to 800 from 1400. :rolleyes:

Share this post


Link to post
Share on other sites

Your welcome.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this