Sign in to follow this  
knappster69

Sudden Loss Of Power

Recommended Posts

Hello,

I have been trying to figure this issue I have now for months. Basically when i drive, there is a sudden loss of power. Try to accelerate and the engine wants to die. The check engine light comes on but then after starting several times, the check engine light turns off. The code will not hold or the check engine light will not stay on long enough to get a code off. This issue does not happen all the time (intermittenly). The last time i had this same problem was about a month ago. Then this morning it happened again. It is like you can drive down the road perfectly fine then its like the engine chokes up on it self. MAF, TPS, EGR have all been replaced.

NE IDEAS??????

Share this post


Link to post
Share on other sites

I had the same problem and it wasn't the battery. I went to Pepboys and they said it was a fuse and I had to eventually change the battery to so get ready to fork over a lot of money! But take it to a mechanic and see how much they say I paid 400 with the tow, service and multiple batteries and oxygen sensor

97 Es300 Oyster Pearl

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this