Sign in to follow this  
cobalt & lexus

Strange Alignment After New Struts

Recommended Posts

After replacing all 4 struts on my 99RX300, strut mounts, and bearings too I'm having strange reaction to handling.

If I make a left turn and then straighten out to drive it pulls to the left. When I make right turn and straighten out to drive, it pulls to the right. If I stop and over correct the wheel it will drive without pulling.

According to the alignment at the local shop (not dealer) it is within standards, however after taking it apart several times to confirm everything is indexed correctly it still pulls. tried rotating tires.

Prior to changing it drove perfectly with 240,000 miles. Local shop mentioned "memory steer" but I can't find anything regarding this condition.

Has anyone had this issue?

Share this post


Link to post
Share on other sites

No, changed all of my struts and experienced no such thing. Memory steer (yep the old snow job on the customer) that makes me furious. They screwed something up....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this