Sign in to follow this  
ClarkKent

P0171 & P0174 Check Eng. Light & Trac Off Light Came On

Recommended Posts

Hi everyone,

Wondering if someone has the same problem I'm having right now. I've a 2001 Lexus ES300 and just love the car. Recently my check engine light and trac off light came on at the same time. I pulled the codes and they are P0171 & P0174. Does anyone knows exactly what the problems are? I cleaned the MAF (Mass Airflow Sensor) with electronic cleaner and clear the codes. It came back on after couple days later. The car currently has 110,000 miles and never done the spark plugs or fuel filter change. I read some posts and people claimed it might be the faulty MAF. If anyone has any idea, your help is greatly appreciated! :rolleyes:

Share this post


Link to post
Share on other sites

According to the 2000-2001 ES300 repair manual, here are the trouble areas for the P0171 error code:

- air induction system

- fuel injector blockage

- MAF meter

- engine coolant temp. sensor

- fuel pressure

- gas leak on exhaust system

- open or short in Bank 1, 2 Sensor 1 circuit

- ECM

For most people who encounter this particular error code, the problem lies in the pre-cat oxygen sensor (up stream). There are 2 sensors and either one or both of them could be delivering a bad circuit. When I replaced 2 sensors, cleaned MAF (recommend that MAF sensor is cleaned every 20,000 miles) and replaced air filter, the car gave me more power and less on Gas from 19 to 22.5 mpg. Or if you prefer, you can take your car to an independent service shop who is familiar with Lexus/Toyota vehicles and get the sensor(s) diagnosed. Hope this info helps out

Share this post


Link to post
Share on other sites

Hi Lexlogic,

Thank you so much for your findings and suggestions. Looks like there are a lot of things that can cause the problem. I already ordered a new MAF sensor and I will give that a try first and see if that will take care of the problem. Do you know if there's a specific area I should look into if both P0171 (system too lean bank 1) & P0174 (system too lean bank 2) are pulled from the scanner?

Thanks again!

Share this post


Link to post
Share on other sites

I had my check engine light come on I need a o2 sensor. I notice if your tires happen to spend on dirt or you pull of fast the traction light come on. If your traction light comes and won't go off pull the battery out for a couple of minutes.

Share this post


Link to post
Share on other sites

Got the new MAF sensor and installed plus clear the codes. After driving half a tank of gas, the CEL and Trac Off lights still come on but this time the codes are P0172 (System too rich Bank 1) & P0175 (System too rich Bank 2). I most likely have to bring the car in to the dealer and find out exactly what's wrong with it. Hope the damage isn't too bad so it doesn't cost me an arm and leg.

Share this post


Link to post
Share on other sites

Clark, I know this was 9 year ago, but do you remember what the solution was. I have the exact same problem with the exact same car, with just a little more miles on it?? I would really appreciate it if you had any conclusions for me!! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this