Sign in to follow this  
Apues01

1992 Ls400 Electrical Issues

Recommended Posts

I have a 1992 ls400 and the alternator went out. before the alternator went out the dash lights would flicker when i would accelerate, and they would disappear when i would get under 15mph while hitting the brake. the cause of the alternator going out was the power steering pump leaking into it, but once it finally went it took a bunch of stuff with it.

once i put the new alternator in and replaced the dome light fuse in the engine fuse block the headlights, power locks, a/c unit, and brake lights. now i have issues with the gauges, fan motor, heat, running lights for the brakes, moon roof (goes up, but not down), and stereo doesn't work.

i have power to all the fuses in and out of the car, but still all the stuff above doesn't work. i thought it might have been the integration relay but that wasn't it. there is power to all the stuff that doesn't work. i think it might be a short circuit? but i don't know where it would be.

if anyone could help me out that would be amazing! Thanks in advance for your help! :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this