Sign in to follow this  
pgmtls

2004 Navigation Nav Lost No Satellite Signal

Recommended Posts

I've seen several posts on this and other sites regarding this issue, but never any resolution outside of issues with tint or after market satellite radio add ons. My GX does not have either. The fact that there is no satellite signal icon in the upper left hand corner of the screen beneath the compass is probably a big clue, but I'm at a loss for what to try next. So far, I've torn the dash apart just to be sure everything is connected properly and it appears to be so. I've calibrated the system time and time again but that only works until it gets lost again. I do know that the windshield was replaced prior to my owning the vehicle, but without a schematic or detailed wiring diagram it's difficult to know what to look for. I would like to be able to trace the antenna from the head unit to its end but would need a diagram for that as well. It would be great to hear from someone who has a comprehensive understanding of the Navigation system and its related components, but any other intelligent troubleshooting ideas would be great also?

Thanks,

terry

btw/ I'm comfortable tearing things apart, using a multimeter, flame thrower, etc.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this