dustincstn82

1994 Sc400 "brake" Light On And No Cruise.....

Recommended Posts

The cruise light turns on and off as it should but does not engage. brakes work fine along with all lights. i read an older post about the same problem but didn't gather much. The only possible solution that seemed like something i would want to tackle was the "brake switch" being "shifted" or something to that effect. It's nice to find solutions on here and I hope to have the same outcome with this problem. I'm mechanically inclined but will not mess with anything unless well informed.

Share this post


Link to post
Share on other sites

I would suspect that a defective (or out of place) brake switch could affect the cruise control. However, one thing it definitely affects is the ability to move the transmission shift lever out of park. When this switch goes bad, the only way to move the shifter is to use the override underneath the cover on the console.

You do not mention this as a problem; therefore, I would suspect that the brake switch is not involved. This particular switch is located near the top of the brake pedal. As the pedal moves forward with the application of the brakes, a switch is depressed. This switch causes the brake lights to illuminate. This same switch is electrically connected to the transmission shift lever and allows the shift lever to be moved after the car is cranked.

Share this post


Link to post
Share on other sites

I would suspect that a defective (or out of place) brake switch could affect the cruise control. However, one thing it definitely affects is the ability to move the transmission shift lever out of park. When this switch goes bad, the only way to move the shifter is to use the override underneath the cover on the console.

You do not mention this as a problem; therefore, I would suspect that the brake switch is not involved. This particular switch is located near the top of the brake pedal. As the pedal moves forward with the application of the brakes, a switch is depressed. This switch causes the brake lights to illuminate. This same switch is electrically connected to the transmission shift lever and allows the shift lever to be moved after the car is cranked.

What about the cruise control? Mine doesn't have the break light problem, it just won't set the cruise on or set at all? any suggestions? is there a fuse to check or something?

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...