Sign in to follow this  
Camelot.King

1999 Es300 What Is The Computer "89661-0W104-84" Doing?

Recommended Posts

Hi

I send my 1999 ES300 to dealer for CEL/TRACOFF up(P1155 and P1135).

They told me that the root cause is the computer "89661-0w104-84". I need to replace it, $800+$300 labor.

Does any one know

(1) What's the function of this computer?

(2) Do I need to program it if I install a used one?

(3) What's the difference between this one and ECM?

Thanks in advance

Share this post


Link to post
Share on other sites

I'm at a loss. :(

http://www.lexuspartsnow.com/components/1999-lexus-es300~electronic-fuel-injection-system-84-04-2274.html

that lexus part seems to be refering to a fuel injection controller module. yet lower it shows it as part of a ECM... but... the haynes says thats the PCM going by the diagram placement matching the lexus one. unsure.gif

what the hell?? lol

btw, a search turned up a previous thread on the same codes and errors/problems.

http://us.lexusownersclub.com/forums/index.php?showtopic=24004

sorry i cant shed some more light on this. im drawing a blank.

Share this post


Link to post
Share on other sites

I'm at a loss. :(

http://www.lexuspartsnow.com/components/1999-lexus-es300~electronic-fuel-injection-system-84-04-2274.html

that lexus part seems to be refering to a fuel injection controller module. yet lower it shows it as part of a ECM... but... the haynes says thats the PCM going by the diagram placement matching the lexus one. unsure.gif

what the hell?? lol

btw, a search turned up a previous thread on the same codes and errors/problems.

http://us.lexusownersclub.com/forums/index.php?showtopic=24004

sorry i cant shed some more light on this. im drawing a blank.

Hi BoaR

Thanks a lot.

I have replaced the A/F sensor 3 times. I got both P1155 and P1135. First time, I used Bosch. It was not working. Then I replaced with Denso. It was not working. Last week, I bought the OEM part directly from Lexus dealer. The same thing happened.

I gave my car to dealer Wednesday. They spent 2 days and told me that they suspected the ECU has problem. However, it's not sure.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this