Sign in to follow this  
xman788

Am / Sat Button Doesn't Work !

Recommended Posts

MY 2008 Rx 400h has the M.Levison System. When I got the car the XM RADIO was not in used. Now I want to subscribe to XM radio but I cannot get the Radio ID. I pressed the AM/SAT button but only AM radio shows. Any Help Please!!!! thanks.

Share this post


Link to post
Share on other sites

MY 2008 Rx 400h has the M.Levison System. When I got the car the XM RADIO was not in used. Now I want to subscribe to XM radio but I cannot get the Radio ID. I pressed the AM/SAT button but only AM radio shows. Any Help Please!!!! thanks.

When i hit the AM/SAT button it only goes to AM, so there's gotta be something else to it. Maybe you need to hold it down? What do the instructions say?

Share this post


Link to post
Share on other sites

MY 2008 Rx 400h has the M.Levison System. When I got the car the XM RADIO was not in used. Now I want to subscribe to XM radio but I cannot get the Radio ID. I pressed the AM/SAT button but only AM radio shows. Any Help Please!!!! thanks.

You should have a paper with the owners manuel that should show the radio ID#. I think you need to have the radio activated in order for it to work when you hit the button. So look through the papers to see if you see a sat radio booklet with the id code for your radio and then try activating it with xm and see if it works.

Share this post


Link to post
Share on other sites

Are you sure you have the XM tuner and antenna hardware installed? I think XM was an option that had to be installed separately.

Share this post


Link to post
Share on other sites

Are you sure you have the XM tuner and antenna hardware installed? I think XM was an option that had to be installed separately.

That is a posibility, However when I got the car it used to show SAT1, SAT2 and so on when I press the AM/SAT button. now I press so many times and nothing. How do I know if it has a tuner and where can it be???

Share this post


Link to post
Share on other sites

The tuner's in the back behind the tool tray. It's easier to just look for the antenna. If it's factory, it's supposed to be mounted on the rear roof on the left side opposite the mast antenna. If the XM tuner is working, it should go to channel 1, which just runs ads for xm. Then you tune to channel 0 for the radio ID.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this