Sign in to follow this  
davispb

Need '99 Buying Advice-Please?

Recommended Posts

Hello all- I don't post much (unless I have something of substance to add) and I own a '92 and mom has a '97, but I am looking at a '99 and I am wondering if you '99 owners can give me some insight as to what the particular common issues are regarding the '99. I have been inside and out of the '92 and '97, so I know their quirks, I'm just not familiar with the '99 and what I should be looking for in particular. Little background on this '99-137k, had tb/wp done at 120k (that's a gold star) small ding in the deck lid (I can live with that)-it's the jade pearl color w/ tan leather (my favorite!) I haven't seen the vehicle yet, just wanted some advice before I inspect. Any help would be much appreciated! Thank you in advance!

Share this post


Link to post
Share on other sites

WELL, my 99 is a pleasure. 140k,

most complaints I have had is door locks not working with KEY fob. make sure ALL 4 doors will lock and unlock. I have fixed mine.

tranny mount replaced.

front strut rod bushings replaced.

engine mounts replaced.

starter contacts replaced.

and it gets 30mph at 80mph on the highway with AC on

post-5365-128164690467_thumb.jpg

Share this post


Link to post
Share on other sites

WELL, my 99 is a pleasure. 140k,

most complaints I have had is door locks not working with KEY fob. make sure ALL 4 doors will lock and unlock. I have fixed mine.

tranny mount replaced.

front strut rod bushings replaced.

engine mounts replaced.

starter contacts replaced.

and it gets 30mph at 80mph on the highway with AC on

I've been lurking and watching your updates on that '99, Billy. I was hoping for your opinion. I noticed you decided to keep the '97 and part ways with the '96. (clever procedure on that starter, btw)

Share this post


Link to post
Share on other sites

WELL, my 99 is a pleasure. 140k,

most complaints I have had is door locks not working with KEY fob. make sure ALL 4 doors will lock and unlock. I have fixed mine.

tranny mount replaced.

front strut rod bushings replaced.

engine mounts replaced.

starter contacts replaced.

and it gets 30mph at 80mph on the highway with AC on

I've been lurking and watching your updates on that '99, Billy. I was hoping for your opinion. I noticed you decided to keep the '97 and part ways with the '96. (clever procedure on that starter, btw)

yep the 97 is the one we put the TB/WP in last september, so it is good for the rest of my life. plus I replaced the strut rod bushings in it too, and have the motor supports for it also and have already replaced the tranny mount.....

ALSO on the 99, I replaced the front brakes & rotors...

THE 97 below....

post-5365-128165748861_thumb.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this