Sign in to follow this  
rkr

Failed Emission Test

Recommended Posts

Took my 1999 Rx 300 in for PA inspection and it failed the emissions test. Mechanic replaced thermostat and both sensors but Check engine light still comes on they had to give me a waiver on the emission test because in PA if you spend over $150.00 they will give you a 1 year waiver. I don't know what to check now or where to start. Any suggestions what could be causing the Check engine light to stay on?

Share this post


Link to post
Share on other sites

Yes it was PO125 they replaced temp switch and sensor, Tell me this car sends false codes, so I wouldn't know where to begin. If they fix everything the code says and it still reads the same, what good are the codes if it happens to be a false one? I hate spending money and still havine the problem.

Share this post


Link to post
Share on other sites

Try and google that code and see what it is. I have had my "check eng" light come on with the "Trac off" light before and I was told it was a comon problem with this vehicle, but my car passed smog. Google the code and see what the code is for. And start there.

Share this post


Link to post
Share on other sites

Find the test procedure that has the same name as the code, and do it. Otherwise, its a guess.

Share this post


Link to post
Share on other sites

I would reset the code and drive it, then hopefully a secondary code comes up....Probably the Air/fuel sensors going bad.....

Share this post


Link to post
Share on other sites

I would reset the code and drive it, then hopefully a secondary code comes up....Probably the Air/fuel sensors going bad.....

Thanks for the info, I thought about replacing O2 sensors but they are pricey. Should I do the front one first, being it is easier to get to? Anyone ever try cleaning the O2 sensors? Can it be done?

Share this post


Link to post
Share on other sites

I would reset the code and drive it, then hopefully a secondary code comes up....Probably the Air/fuel sensors going bad.....

Thanks for the info, I thought about replacing O2 sensors but they are pricey. Should I do the front one first, being it is easier to get to? Anyone ever try cleaning the O2 sensors? Can it be done?

I would reset the code and drive it. why put more money into it until you know that part needs replacing. You can test the o2 sensors and see if they are working. good luck.

Share this post


Link to post
Share on other sites

Heres an PDF file on checking the 02 sensor hope this helps you out. B)

Thanks for the tip , I'll give it a shot and check the sensors. Can you clean the sensors with MAF cleaner?

Share this post


Link to post
Share on other sites

one note, do not use aftermarket sensors for the Air/fuel (Bosch) Use Denso only and somewhere U read they are real down in price, Amazon has them for around $100 or less for the Denso.....I believe it is a 234-9009

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this