Sign in to follow this  
DubbyM

04 Rx Ac Problem

Recommended Posts

My 04 RX330's AC compressor turns off after about 5 minutes of run time. I can turn the system off and then back on and it will operate again for about 5 to 10 minutes and then drops out again. Any ideas as to what to look for? Thanks in advance!

Share this post


Link to post
Share on other sites

Sounds like your compressor clutch is beginning to fail. You should be able to replace the clutch assembly without having to replace the compressor. I suggest you have it checked out by a reputable A/C shop in your area to confirm the issue. Clutch assemblies are relatively inexpensive. Hope that's what it turns out to be for you. I assume that when your A/C compressor is running, it cools the vehicle normally - correct?

Share this post


Link to post
Share on other sites

Yes, it cools fine then I notice that it's putting out warm air (fan still runs). I push the off button and then push it again and the A/C is cool again. Lasts about 5 or 10 minutes and warm air again.

Share this post


Link to post
Share on other sites

Yes, it cools fine then I notice that it's putting out warm air (fan still runs). I push the off button and then push it again and the A/C is cool again. Lasts about 5 or 10 minutes and warm air again.

I encountered this same problem this summer. My problem ended up being one of the cooling fans was not operating correctly. I could bump the housing and it would come on, but after a while it would stop working again. This was also causing my engine temperature to register higher if I was stopped at traffic lights or left engine running.

The fix was replacing the driver side cooling fan assembly. I replaced the ECM for the fans myself: $359.00 then ended up paying another $500.00 for the fan and the dealership to replace it.

Good Luck on your fix

Ray

Share this post


Link to post
Share on other sites

My girlfriend is having a similar AC problem on her 2004 Lexus where it turns on, then shuts off. Now in our case, the AC pump does cycle on/off which I believe is normal to keep the system on a regulated pressure level. Each time the AC pump cycles, the fans kick on. However, the cooling fans will not continue once the AC pump shuts off at MAX AC. I believe the fans should be running all the time during max cold...correct? The AC radiator feels hot, so there is definitely refridgerant compression taking place. Also, the fans turn on whenever the engine needs cooling. I did some internet searching and found there is a TSB 00203 related to "loss of AC performance" which sounds like our deal. Anyone know if this TSB replaces a sensor, cooling fan computer, or something else?

Of course Lexus wants to charge us $100 to diagnose, probably another $400 for the part and then some bend over labor charges.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this