Do Not Sell My Personal Information Jump to content

93 Sc400 Side Mirrors Not Working


Recommended Posts

I just bought a 93 SC400 and both side mirrors will not move when you use the try to operate them. I have a second 93 SC400 that has the same problem so it appears to be a common problem with these cars does anyone know what might be causing this? By the way the latest SC400 I just bought is a beauty (4K) it is the green with gold letters but it does not have some of the extras my other SC has like no heated seats and no nakamichi but it does have the multi cd player and it still sounds good does anyone know what brand they put in that year was it BOSE?

Link to post
Share on other sites

I just bought a 93 SC400 and both side mirrors will not move when you use the try to operate them. I have a second 93 SC400 that has the same problem so it appears to be a common problem with these cars does anyone know what might be causing this? By the way the latest SC400 I just bought is a beauty (4K) it is the green with gold letters but it does not have some of the extras my other SC has like no heated seats and no nakamichi but it does have the multi cd player and it still sounds good does anyone know what brand they put in that year was it BOSE?

dude, Check your fuse box (number 7) on the driver side. If they are not blown it most likely the mirror ECU

http://www.clublexus.com/forums/sc-400-300/242287-power-side-rear-view-mirrors-dont-work.html

elecricalcomponents.jpg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...