Sign in to follow this  
bmike74

98 Es300 Back Up Lights And License Plate Lights Out

Recommended Posts

I have a 98 ES300, last week when driving the "replace bulb" and "Reverse" displays lit up on the dash. Then shortly thereafter went off again. One day later, they were back on to stay. I consulted the manual and determined that I would need to replace the back up lights. But then I found that both back-up lights and the license plate lights were all off. I checked all of the fuses on the drivers side panel, with no luck. I also checked the connections by the lights and they seemed ok.

Any ideas as to what could be the problem would be greatly appreciated.

Share this post


Link to post
Share on other sites

You don't say whether you checked to see if the bulbs were burnt out or not. Start there. As for the backup lights, if the bulbs are fine, check to see if the reverse light switch on the transmission has a broken or corroded connection, or that the switch needs replacing. Good Luck!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this