Sign in to follow this  
acline

Rx300 Trailer Wiring Harness

Recommended Posts

I recently installed a hitch on my 2002 Lexus RX300. I bought a Curt wiring harness from hitchsource.com and plugged it into the connector located in front a the driver's side rear bumper. I hooked a test connector up to the 4 pin connector and I am not getting power. I did install a 20 amp fuse into the tow slot in the fuse box(I tried several fuses to rule out the possibility of a bad fuse). Anyone have any idea why I am not getting power to the connector? I did look in the compartment where the spare tire is located and there is a white plug that has 10 or so slots in it. Is it possible that I need a power module or converter to plug into that connector? Any help would be appreciated. Thanks.

Share this post


Link to post
Share on other sites

I just confirmed with the Lexus parts dept. that a power converter is necessary to supply power to the trailer wiring harness. There are actually two part numbers for the converter. The converter listed individually is actually more expensive than if you have them order the converter and bracket that is listed as part of the factory tow package. Makes sense huh? Anyway, the part number I ordered was 08940-48010 and was $87.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this