Sign in to follow this  
Aristo82

Need Advice On Dice Mediabridge Setting

Recommended Posts

I just bought a used 06M GS300 (Non-Navi, Non-ML, No Factory SAT) several days ago and have been enjoying the ride so far.

Few days ago I bought the DICE MediaBridge off of Amazon and installed it.

I left the dip switch setting to SAT mode (both switches on) and was able to get sound coming out. However, sometimes cycling the ignition off/on will cause the radio to turn off on its own. I can turn the radio back on but pushing the AM/SAT button will only allow me to select AM RADIO (should come up with SAT menu which is used by the DICE box).

The strange thing is that if I switch to CDC mode (both switches off), I don't have any issues with the radio turning off on its own and not seeing the DICE box. It seems to work just fine although I would prefer to use SAT emulation.

About to open a support ticket with DICE but wanted to see if I can get some input from others first.

So my question is, for other DICE MediaBridge users out there with my configuration...

-What dip switch mode are you using

-Have you guys seen similar problem as mine with dipswitch set to SAT

Any input would help at this point. Thanks in advance.

Share this post


Link to post
Share on other sites

I just bought a used 06M GS300 (Non-Navi, Non-ML, No Factory SAT) several days ago and have been enjoying the ride so far.

Few days ago I bought the DICE MediaBridge off of Amazon and installed it.

I left the dip switch setting to SAT mode (both switches on) and was able to get sound coming out. However, sometimes cycling the ignition off/on will cause the radio to turn off on its own. I can turn the radio back on but pushing the AM/SAT button will only allow me to select AM RADIO (should come up with SAT menu which is used by the DICE box).

The strange thing is that if I switch to CDC mode (both switches off), I don't have any issues with the radio turning off on its own and not seeing the DICE box. It seems to work just fine although I would prefer to use SAT emulation.

About to open a support ticket with DICE but wanted to see if I can get some input from others first.

So my question is, for other DICE MediaBridge users out there with my configuration...

-What dip switch mode are you using

-Have you guys seen similar problem as mine with dipswitch set to SAT

Any input would help at this point. Thanks in advance.

Share this post


Link to post
Share on other sites

Ya I'm having the same problem (among others). Mine was professionally installed for over $500 and I will be returning the Dice unit for a refund. I have to pull over and shut off the car to get the car to recognize the Dice. I'll try the Grom which might not be perfect but it's half as much money. I think it's time to roll the Dice. :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this