Sign in to follow this  
kuziwk

Tranny Fluid Change

Recommended Posts

so i changed the fluid,pulled off the pan cleaned it nice and changed the filter. I added two litres of oil, the tranny shifts very smooth. After taking it for a drive i checked the level again which used to be good but is now showing no oil while its running not even in the cold??? there are no leaks as i checked it over. Also on Lexs tutorial site it said the drain and refill amount is 1.9 litres?

Share this post


Link to post
Share on other sites

so i changed the fluid,pulled off the pan cleaned it nice and changed the filter. I added two litres of oil, the tranny shifts very smooth. After taking it for a drive i checked the level again which used to be good but is now showing no oil while its running not even in the cold??? there are no leaks as i checked it over. Also on Lexs tutorial site it said the drain and refill amount is 1.9 litres?

Just add some more fluid until you get the correct level; more than 1.9 litres could have drained out.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this