Sign in to follow this  
eugenez

00' Es300 90000 Miles

Recommended Posts

I have a problem. I don't know if it is a big deal or not but every time I accelerate at low RPM there is a rattle noise coming from the engine. When RPM's go up like past 3000 it stops or maybe the noise of the engine cover it up. But I don't know what to do to make it go away.

Share this post


Link to post
Share on other sites

Sounds like it could be timimg belt tensioner or pulley related. Get the car to a tech and let them hear the noise to ensure its not going to do major damage. Good Luck!

Share this post


Link to post
Share on other sites

Eugene,

My '93 es300 had a loud rattle at certain rev range. It came from the air conditioner compressor, or the pipes from it. Holding a pipe firmly deadened the noise. I used a couple of nylon cable ties to pull the 2 pipes together a bit. This almost, but not quite, fixed the problem. The air conditioner works fine, by the way. Maybe its some serious internal problem, but I don't think so.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this