Sign in to follow this  
hazeleyes

Check Engine & Vsc Lights Come On, Transmission Goes Out 1 Month L

Recommended Posts

Hello This is my first post here.

I have a 2001 RX300. I bought it in 6/2009 at about 72,000 miles.

This winter, my check engine and vsc lights came on. The first time I needed an o2 censor replacement and new batter (about $500).

About one month later it came back, I took it to the Lexus dealership and they told me I needed a new catalytic convertor, a $2500 repair that I decided to wait on fixing. They went ahead and turned the light off for me, I drove it for about 2 weeks until the light came back on.

Last week, my transmission went out completetly. I need an enirely new transmission, which is thankfully covered by my extended warranty. Catalytic convertors are not covered by my warranty.

Here is my question, do you think the check engine and vsc lights could have been related to the transmission, or will I still need a catalytic convertor? Or do you think that is really the problem?

I asked my mechanic to check the hoses as suggested in another thread. They said that they did but I'm not sure I've I believe them.

Any input is greatly appreciated. Thanks!

Share this post


Link to post
Share on other sites

Hello This is my first post here.

I have a 2001 RX300. I bought it in 6/2009 at about 72,000 miles.

This winter, my check engine and vsc lights came on. The first time I needed an o2 censor replacement and new batter (about $500).

About one month later it came back, I took it to the Lexus dealership and they told me I needed a new catalytic convertor, a $2500 repair that I decided to wait on fixing. They went ahead and turned the light off for me, I drove it for about 2 weeks until the light came back on.

Last week, my transmission went out completetly. I need an enirely new transmission, which is thankfully covered by my extended warranty. Catalytic convertors are not covered by my warranty.

Here is my question, do you think the check engine and vsc lights could have been related to the transmission, or will I still need a catalytic convertor? Or do you think that is really the problem?

I asked my mechanic to check the hoses as suggested in another thread. They said that they did but I'm not sure I've I believe them.

Any input is greatly appreciated. Thanks!

I have 2002 RX300 with 125K mi. I also had Check Engine and VSC come up together few times. It was always related to the fuel vapor system, or simply put faulty gas cap. Replaced it with original Lexus gas cup (24USD at a dealer) and never had this problem again. If you have those lights on, try to get OBD II code read by someone, who you can trust. It is first step to the proper diagnostic. Those lights could not relate to transmission so you should be OK there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this