Sign in to follow this  
SlipAngle79

1990 Ucf10 Owner

Recommended Posts

Hello all, as of 2 weeks ago I am the proud owner of a black/tan 1990 LS400. It is rough but the mechanicals and driveline are smooth even with 236,000 miles on the analog odo! I have driven several various UCF's over the years and have some life and death stories which I will share at some point in time on here. First though, I have questions.

I bridged the CEL and TRAC OFF codes and the CEL=bad o2 sensor on the right bank (no biggie) but the TRAC OFF came back as a computer control malfunction? Any insight on how to get the TC working again? The TRAC light is not on, only the TRAC OFF on the bottom of the guage cluster.

Things I have discovered: There is NO CABIN AIR FILTER on 90-92 (UCF10 V1) LS400's FYI. I was a little bummed by that :(

There is NO LIMITED SLIP DIFFERENTIAL in 1990 LS400's, is there one in later years?

After pulling the pass door apart to fix a broken handle I discovered that the Nakamichi speakers all have one amplifier per speaker, similar to BOSE factory audio, is this correct? I noticed the 4" (blown) door speaker in mine is surrounded by black plastic which looked to be an amplifier?

Can you guess how much I paid for this car ;) ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this