Sign in to follow this  
SeanGTS

Just Bought 2004 Es33

Recommended Posts

Just bought a silver 330, 2004 with 90k for 11 grand. Pretty happy with it.

Few problems, the intermittent wipers don't seem to work. I notice the auto function, that doesn't seem to work either? The other wiper settings seem to work just fine, any thoughts?

Their is an orange light illuminated on the dash, I believe its for a rear tail light not working. The middle brake light in the rear window stopped working about halfway home. Is this an easy fix? Do you have to replace multiple LED's? Is this a common problem?

Share this post


Link to post
Share on other sites

Welcome to the club...

Is the sensor working? Turn the car on, put the wipers on the auto setting, set the sensitivity to the most sensitive and pour some water over the sensor and see what happens. If nothing happens something is wrong with the sensor.

I think you can just disconnect the sensor and they become normal intermittant wipers...

The third brake light is very easy to replace, I just did it. Just slide the housing towards the passenger side and it will lift right off. Then unplug the wire and the whole housing will come loose. You twist the socket out, swap out the bulb and thats it. Your year ES doesn't have any LEDs, they are all incandescent bulbs...

Share this post


Link to post
Share on other sites

Welcome to the club...

Is the sensor working? Turn the car on, put the wipers on the auto setting, set the sensitivity to the most sensitive and pour some water over the sensor and see what happens. If nothing happens something is wrong with the sensor.

I think you can just disconnect the sensor and they become normal intermittant wipers...

The third brake light is very easy to replace, I just did it. Just slide the housing towards the passenger side and it will lift right off. Then unplug the wire and the whole housing will come loose. You twist the socket out, swap out the bulb and thats it. Your year ES doesn't have any LEDs, they are all incandescent bulbs...

Yes, the brake light was very easy :)

You're correct, they do not work at all regardless of the sensitivity. I have read elsewhere that it is possible to reprogram the wipers, I will try your method. Thank you very much, I will let you know how it all works out!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this