Sign in to follow this  
Hadyourphil

2001 Rx300 Driver's Side Front Window Issues

Recommended Posts

This thing is driving me crazy. I put those snap-in wind deflectors in all four windows a couple of years ago, and all the windows have operated fine except the driver's window, which never has. That one has had to be coaxed up to close. I realise that is the jam or pinch circuitry activating, but I can not figure out how to adjust it. I have the manual on a CD, which aside from some really cryptic appreviations for topic headings, is pretty good. But, nothing on adjusting the window. I've read that there might be something in the owner's manual, but don't see any reference in my manual.

And, to add to the fun, it recently has taken to going down, but not coming back up! I've taken off the trim panel and have determined the switch is OK, and there is a click coming from the motor(?) when I activate the switch. Every now and then, it goes back up. Believe me, if I can get it back up tonight, that's where it will stay... until I can figure out what the problem is.

Any ideas? Suggestions??

Share this post


Link to post
Share on other sites

Try this:

Put the window all the way up and keep the switch pulled up for about four more seconds and put it back down. It worked for me.

The window tracks should be lubricated with a Silicone spray, or the jam ....pinch thing will just kick in again.

Karl

Share this post


Link to post
Share on other sites

OK, I'll try that... but not until I get back from a road trip to VA. The last thing I want is a stuck-open window in the dead of winter!!

Have to ask... How did you arrive at that particular solution?

Share this post


Link to post
Share on other sites

<Have to ask... How did you arrive at that particular solution?>

This info came from a Lexus technician.

Share this post


Link to post
Share on other sites

Same thing happens in my car on both driver and passenger side.

After resetting the pinch (pulling the switch up for a while) has made it better but still every now and then it acts weird.

Share this post


Link to post
Share on other sites

I tried the pinch reset, but it doesn't offer much improvement.

What bugs me is, I have four tinted "eyebrows" thar fit in the top of each window channel, and the window closes on them. Of course, the only window that won't work right (or now, at all) with the "eyebrow" is the driver's window. Window goes up, and comes right back down. Then, it is a real struggle to get the window to go back up. This is after I've removed the eyebrow in frustration. Frequently, pushing the switch "up" makes the window go down.

I am absolutely at my wit's end about this. Does anyone have any solution? Have you experienced similar issues?? What do I have to replace? Is there any other adjustment aside from that "hold the switch" solution??

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this