Do Not Sell My Personal Information Jump to content

2002 Rx300 Sluggish After 30k Service


daveb12
 Share

Recommended Posts

I have a 2002 RX300 that was perfect.

I took it in for the 30K service and it has not run correctly since!

I am not sure if it is the tranny or not.

The only way I can describe it is "sluggish".

The car does not want to go. When I take my foot off the gas it slows. Almost like the emergency brake is on.

What did they do to my RX at that service?!?!?!

Any help is appreciated.

++db

Link to comment
Share on other sites

Car still acting up.

Here is what they did on the 30k service.

Brake Fluid

Air Filter

Bulb

Wiper Blades

Transmission Fluid Exchange Service:

1 ASKiT53 Trans Service

15 00279-DRMT4-01 ATF T-IV

Trans Fluid Exchange

Coolant System Fluid Exchange

No Oil as we had the oil done last week.

Total cost $497.94

Please advise why the car comes almost to a stop from 65 when I take my foot off the gas.

Thanks,

Dave

daveb12@adelphia.net

Link to comment
Share on other sites

Brake Fluid

Transmission Fluid Exchange Service:

1 ASKiT53 Trans Service

15 00279-DRMT4-01 ATF T-IV

Trans Fluid Exchange

I'd say they screwed up either when the changed the brake fluid or the transmission fluid. But I can't say specifically what they did wrong. If it was my car I'd get another diagnosis from another Lexus dealer and when the fault is determined, the first dealer should be held financially responsible.

Link to comment
Share on other sites

Not sure what they did "wrong" at the 30k service, but, we took it back on Friday and they "reset the computer" and it is running much better.

I can't tell if it is back to 100% because of all the time that passed since the service and the fact that the loaner was an RX330 (felt more powerful) and I just bought a car with 300 HP. So, the RX feels SLOW to me.

It is much better. Thanks god for computers. :-)

++db

Link to comment
Share on other sites

it's psychological! the reason why you're feeling sluggish b/c our brain, expected that the car would be riding smoother, faster, and better, etc... after the service. but since that's not how things works, instead the expectency of our brain to the object making us thinks that the car is sluggish. but really... it's the same! servicing/repairing the car doesnt make it go faster after it was used and have more than 5000 miles.

i know this b/c i've changed car's oil every 3000 miles. everytime when i get the oil changed, in my mind im expecting the car to go faster and smoother. but instead i felt sluggish. b/c the car still runs the same, so it opposits of your though.

get what im saying?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership