Jump to content


Fuse/replay Problem, Please Advise


breinhar

Recommended Posts

Hello All,

This is my first time posting on your forum and I am hoping that someone can help me out. My father had a 96 Lexus ES300 sitting on the side of the house for like a year. I put a new battery in it and started right up, (good huh? :) ) Anyway, I moved it into the garage to do some other work on it. Then next time I go to start it, no go. So I thought maybe there was more issue with the battery but I tried another that worked and still no go.

Upon further investigation I found that anything that had its own fuse still worked (horn, hazards etc..) What doesnt work is any of the dash lights when you turn the key. So you can put the key in, turn it to accessory and no lights come on, and when you turn it to on it doesnt even try.

So I am assuming there is some main engine relay or something of the sort that is causing this. I did find one labled main engine and replace it but that didnt solve anything.

Does anyone on here have experience with the electronics for the ES300 or any suggestions on what else to try?

Thanks very much.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Forums


News


Membership