Sign in to follow this  
vdavid

One Touch Open Or Close For Moonroof

Recommended Posts

My one touch function for my moonroof has stopped working, although I can still operate it by holding the buttons down until it is either open or closed or tilted. So it seems that the motor is fine. I think it stopped working automatically when I had to replace the car's 12V battery. I did what the manual said to reset it, and opened it manually and kept the open button pressed until it started to come down, but it still doesn't work by one touch. Anyone have any ideas short of taking it back to the dealer?

Also, what works best for removing fingerprints from the nav screen? It seems that apparently the oil from my fingertips left marks that can't be removed with just windex or interior detailer. I'm afraid to use any of the plastic polishes that I've seen because they all warn against using it for that purpose. Any ideas?

Thanks a million...

Share this post


Link to post
Share on other sites
My one touch function for my moonroof has stopped working, although I can still operate it by holding the buttons down until it is either open or closed or tilted. So it seems that the motor is fine. I think it stopped working automatically when I had to replace the car's 12V battery. I did what the manual said to reset it, and opened it manually and kept the open button pressed until it started to come down, but it still doesn't work by one touch. Anyone have any ideas short of taking it back to the dealer?

Also, what works best for removing fingerprints from the nav screen? It seems that apparently the oil from my fingertips left marks that can't be removed with just windex or interior detailer. I'm afraid to use any of the plastic polishes that I've seen because they all warn against using it for that purpose. Any ideas?

Thanks a million...

I had the same problem with my moonroof. I unhooked the battery for about 20 mins and when I reconnected it, problem solved. As for the nav screen, I ordered a screen protector from lextasy.com It hasn't been delivered yet, but I'm looking forward to it.

Share this post


Link to post
Share on other sites

I had the same problem with my moonroof. I unhooked the battery for about 20 mins and when I reconnected it, problem solved. As for the nav screen, I ordered a screen protector from lextasy.com It hasn't been delivered yet, but I'm looking forward to it.

Thanks for the great advice....When the fellow came out from AAA to install a new battery, he plugged a temporary power source into my cigarette lighter so that none of my personalized settings would be lost (transmission shift points, radio stations, memory settings) and your solution never occurred to me. I'll try it in the morning, and let you know the result.

Please let us know how well the screen protector works after you install it.

Again, many thanks

Share this post


Link to post
Share on other sites

Open the sunroof all the way, hold the button for 10 seconds, close the roof, hold for another 10 sec, that should work.

Share this post


Link to post
Share on other sites
I had the same problem with my moonroof. I unhooked the battery for about 20 mins and when I reconnected it, problem solved. As for the nav screen, I ordered a screen protector from lextasy.com It hasn't been delivered yet, but I'm looking forward to it.

Tried it this morning but it didn't cure the problem. It still operates manually, but the one-touch feature is gone. I also noticed that it doesn't have the retained power feature that it used to have for about 45 seconds after you turn the ignition off, although this feature works just fine on my windows. Any ideas out there?

Thanks a million for your help.

Share this post


Link to post
Share on other sites
Open the sunroof all the way, hold the button for 10 seconds, close the roof, hold for another 10 sec, that should work.

BINGO!!!! Worked like a charm.

You are the MAN....

Can't thank you enough. It's remarkable how you get so used to these small luxuries that you take them for granted....but miss them SO much when they're gone.

Share this post


Link to post
Share on other sites
Open the sunroof all the way, hold the button for 10 seconds, close the roof, hold for another 10 sec, that should work.

Hello "G", i tried that method on my gs but it's not working. i pressed the open button for 10 seconds, then pressed the 'close' button (it closes in 8 seconds), however, when i press the close button for an additional 2 seconds (10 seconds total) the sunroof pops up from the rear. i have tried this method several times and get the same result. what am i doing wrong? thanks for any advice!

Share this post


Link to post
Share on other sites

We had a similar problem that was fixed by Lexus. I wasn't there, but my wife tells me that the Lexus guys said that the sensor that detects that something is in the way sometimes gets confused. The tech closed the roof with his hand in the way and the roof reacted properly. After this it worked OK. Not sure if he did anything else to fix it.

Share this post


Link to post
Share on other sites
Open the sunroof all the way, hold the button for 10 seconds, close the roof, hold for another 10 sec, that should work.

Hello "G", i tried that method on my gs but it's not working. i pressed the open button for 10 seconds, then pressed the 'close' button (it closes in 8 seconds), however, when i press the close button for an additional 2 seconds (10 seconds total) the sunroof pops up from the rear. i have tried this method several times and get the same result. what am i doing wrong? thanks for any advice!

=============

Thanks! it works! i had my wife re-try with her midas touch!

Share this post


Link to post
Share on other sites

Had same problem today, called dealer, service advisor told me to depress the UP button and hold it until the roof stopped moving. I did so and after the roof had cycled up and down and back and forth the roof worked fine again.

Share this post


Link to post
Share on other sites

After trying the 10 second rule a few times I finally got it to work. If you press and hold the forward/up button (12-15 secs) the sunroof will go through a series of movements. Continue to hold the button until the sunroof comes to a stop in the closed position. The sunroof should be in automatic state now.

Thanks everybody I've been dealing with this issue for months. Every time it rained I would wonder if I got it closed just right.

Share this post


Link to post
Share on other sites

I have the same problem with the moonroof after unpluging the battery cable on my 2006 GS300.

To fix this problem:

You must reset the moonroof for it to work correctly.

Make sure your moonroof is closed. Than Press the UP bottom and hold it for 10-12 second. This will allow the moonroof to do its resetting movement.

After it reset, try pressing the Open, close, up, and down button and see if it funtion the ways it suppose to.

If you get lost, page 136 in your lexus manual book will tell you how to reset the moonroof.

And by the way, you will also need to reset your passenger windows.

Share this post


Link to post
Share on other sites

good day guys

i had similar problem , my one touch operation for the moon roof is working but not properly, this happened after i disconnect the battery and reconnect it.

the first one touch operation should open the moon roof up to the half ,and the second will open it full , what is happening now the first touch open it up to 80% rather than 50% as it was before ,but the one touch closing is working properly and tilted as well

any idea

thanks

Share this post


Link to post
Share on other sites

good day guys

i had similar problem , my one touch operation for the moon roof is working but not properly, this happened after i disconnect the battery and reconnect it.

the first one touch operation should open the moon roof up to the half ,and the second will open it full , what is happening now the first touch open it up to 80% rather than 50% as it was before ,but the one touch closing is working properly and tilted as well

any idea

thanks

You stated the reason yourself. It is because you diconnected the battery. Both the moonroof and power windows will have to be "normalized", in other words, they have relearn their respective programming. The instructions are clearly described in your owners manual and previously in this thread.

Simply stated:

Moonroof: push and hold the UP button unitl the moon roof tilts all the way up and then down a little automatically.

Windows: 1. push down the power window switch for each window using the switch of each door so that the window goes halfway down. 2. then pull up the switch unitl the windows close and hold the switch for one second.

steviej

Share this post


Link to post
Share on other sites

good day guys

i had similar problem , my one touch operation for the moon roof is working but not properly, this happened after i disconnect the battery and reconnect it.

the first one touch operation should open the moon roof up to the half ,and the second will open it full , what is happening now the first touch open it up to 80% rather than 50% as it was before ,but the one touch closing is working properly and tilted as well

any idea

thanks

You stated the reason yourself. It is because you diconnected the battery. Both the moonroof and power windows will have to be "normalized", in other words, they have relearn their respective programming. The instructions are clearly described in your owners manual and previously in this thread.

Simply stated:

Moonroof: push and hold the UP button unitl the moon roof tilts all the way up and then down a little automatically.

Windows: 1. push down the power window switch for each window using the switch of each door so that the window goes halfway down. 2. then pull up the switch unitl the windows close and hold the switch for one second.

steviej

thanks steivej for your comments , i had tried it and never success ,that's why i write in the forums because till now i didn't catch the solution

regards

Share this post


Link to post
Share on other sites

2006 GS 430. OWNERS manual instructions do not work.  What does work is hold up button until roof completely opens and then completely  closes. One touch will be re-enabled.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this