Sign in to follow this  
e34v8driver

Excessive Brake Dust In '96 Sc400?

Recommended Posts

Hi:

Posting for a friend who doesn't know about this board, yet. She's the second owner of a

'96 SC400 and she's complaining about excessive brake dust. My searches of this board

for this issue have turned up very few complaints. I'm wondering if this is a common

complaint with that vintage of the SC, or maybe this car is running with some generiic

(non-factory) brake pads. Can anyone offer any guidance.

Thanks,

Charles

Share this post


Link to post
Share on other sites

I had that on my 91 but i changed my pads and rotors and now it stay pretty clean. might just be the eight year old brake setup getting old...good chance to upgrade

Share this post


Link to post
Share on other sites

My 96 still has the factory pads (50k) & dust has not been a problem, your's have probably been replaced with after market generic pads. Stay with Toyota/Lexus pads, a lot of people prefer "Porterfield" pads because they leave hardly any dust.

Share this post


Link to post
Share on other sites
My 96 still has the factory pads (50k) & dust has not been a problem, your's have probably been replaced with after market generic pads. Stay with Toyota/Lexus pads, a lot of people prefer "Porterfield" pads because they leave hardly any dust.

what compound of porterfield?

their street compound does dust a lot. It's almost like a redish color to it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this