Do Not Sell My Personal Information Jump to content

Sold My Ls And Bought A Gremlin


Recommended Posts


No - I did not BUY a Gremlin - but I'm starting to wonder if my LS HAS a 'gremlin'!!

Last night - as I was out driving - I wanted to adjust the seatbelt anchor thing - but it didn't work. That was odd - I thought - because it worked perfectly fine before. So when I got home - I tried again. This time it DID work. [sorta] I pushed the button and the seatbelt thing went UP [when I pushed 'up'] but then it went DOWN again - AFTER I let GO of the button. I then tried again - and it did the same thing. Third time - it didn't do anything. :( Hmm... So I then I tried other buttons - just to see if everything else was ok. It was [or they are] until I got to the memory seat thing. I pushed the #1 button [the only one that's 'set'] and everything adjusted [as expected] except for the driver's side mirror. It worked - or I should say - it moved - but it didn't STOP moving. It kept tilting upward and wouldn't stop. After about 10 seconds of 'clicking' it finally stopped. I decided to leave the car and go inside the house. [where it was safe!!]

Now I'm just saying a little prayer in hopes that all will be fine - the next time I try.

Any ideas of what could be causing this?!

Craig!! :huh:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...