Jump to content


2006 Rx330 Driver & Passenger Door Locks


MBam
 Share

Recommended Posts

I have a 2006 RX330 that's having issues with the driver and passenger door locks. When trying to unlock the doors using the alarm key, only the rear doors unlock... I have to manually unlock the front two. When I try to lock the doors using the alarm key, the alarm doesn't activate and the front two door do not lock. Again, I have to manually lock the front two doors before the alarm activates. Also, using the lock/unlock button from inside the car doesn't help either.

Is this a common issue and if so, is there a recall or some type of warranty repair? If not, is this a simple fix that I can do myself :D or do I have to win the lottery and get it done at the dealership :( ? Thanks!

Link to comment
Share on other sites

I have a 2006 RX330 that's having issues with the driver and passenger door locks. When trying to unlock the doors using the alarm key, only the rear doors unlock... I have to manually unlock the front two. When I try to lock the doors using the alarm key, the alarm doesn't activate and the front two door do not lock. Again, I have to manually lock the front two doors before the alarm activates. Also, using the lock/unlock button from inside the car doesn't help either.

Is this a common issue and if so, is there a recall or some type of warranty repair? If not, is this a simple fix that I can do myself :D or do I have to win the lottery and get it done at the dealership :( ? Thanks!

MBam- I wouldn't think you would be having failure of the lock motors on an '06. Seems too new for that. Anythings possible I guess. It could be the switch assembly (the electronics in it). I would think the first thing would be to disconnect the battery for about 20 min. and see if it can reset itself. I don't know if that's possible, but it's easy and costs nothing. If that doesn't do anything I would pull one of the front door panels and jump juice directly to the window motor. If that doesn't do anything the lock is probably bad. Both of them would have to be checked in this way. I'm sure there are other things that can be bad but at least that that should narrow it down.

Link to comment
Share on other sites

MBam - I wouldn't think you would be having failure of the lock motors on an '06. Seems too new for that. Anythings possible I guess. It could be the switch assembly (the electronics in it). I would think the first thing would be to disconnect the battery for about 20 min. and see if it can reset itself. I don't know if that's possible, but it's easy and costs nothing. If that doesn't do anything I would pull one of the front door panels and jump juice directly to the window motor. If that doesn't do anything the lock is probably bad. Both of them would have to be checked in this way. I'm sure there are other things that can be bad but at least that that should narrow it down.

code58 - I was surprised myself when the driver-side door lock started to fail and just recently, the passenger side. The car seems too new to have this problem already... especially on two of the doors. Thanks for the suggestions. I'll definitely give them a try and let you know how it goes. Thanks again!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership