Sign in to follow this  
mig25

A/c Heater Control Unit

Recommended Posts

:( I beieve some of the lights in my A/C & Heater control unit are gone, where the buttons that show air that goes to the floor, the two far right ones are not lit at night,... 1990 LS 400. I wonder if I can replace them, where would I get the bulbs? Have anyone done this before? please let me known, thanks :(

:ph34r:welgaby@msn.com :ph34r:

Share this post


Link to post
Share on other sites

Mine does the same thing. The top and bottom lights on the right side are out.

Share this post


Link to post
Share on other sites

Someone posted a message on this before and stated that he had used a solder in lightbulb for replacement . I believe it was a type 2182 bulb although there was some question as to whether the 14V rating was correct. Whatever the case, Mouser Electronics has a good selection of these types of bulbs at various voltage levels that you can check out at this link.

http://www.mouser.com/catalog/616/87.pdf

This is where I will look for replacement bulbs when mine start to burn out.

Curt

Share this post


Link to post
Share on other sites

its a realy hard job to do, i opened my audio headunit to do this job and i gae up coz i was scared to destroy the whole unit.

Share this post


Link to post
Share on other sites

I f you send the unit to Mikado to replace the LCD, do they also fix the bulbs?

Share this post


Link to post
Share on other sites

Must be very common. My 90 LS400 also has lights not working here and these are actually the only lights (inside or out) that does not illuminate. The green lights on all of the buttons still work, but the climate control button illumination lights on the left side do not work. I think the "off-auto-low & medium fan speed-and some of the air vent modes on the left side" do not illuminte. The medium and high fam speed & air vent mode toward the right side still work. I feel it is not big enough of a problem to deal with. If I recall- all of the climate control illumination lights on my old 93 Camry were not illuminating. Perhaps a common problem on many other early 90s Toyotas & Lexus'.

Share this post


Link to post
Share on other sites

I thought it was kind of strange that four light all went out at the same time. They are the four (top and bottom) on the right. Since I have to replace the ac control unit anyway, I figured it would fix it then

Share this post


Link to post
Share on other sites

i've talked to some mechanics that have said it is very rare to see a 1st gen. ls 400 with the climate control lcd with proper illumination. mine is burt out too. you can send it to mikado, like someone said previously, but i've seen the b/f and after of that job and although the lcd is fixed and shows the time and temp., the actually numbers and lighting do not match the oem radio. the numbers after the fix are smaller and in a different font. and the color of the screen is also a different shade. I thought it didn't look very good because it doesn't match the lcd of the oem radio. now, if you have installed an aftermarket cd player or head unit, makido can fix the climate control to match the color of that. ex... the one i saw had a pioneer blue faced head unit, and the replaced climate control, was fixed with matching blue illumintion, and since the oem radio isn't there the font of the numbers didn't matter. just my 2 since thank you

Share this post


Link to post
Share on other sites

Actually, if you guys check out the pinned Thread called Climate/Clock, you'll find two places where they refurbish our Clock and Climate units.

It's a very common problem with our first gen LS400s.

If you're interested in replacing the bulbs yourself, I believe the latter link to Jim Walker has some interesting info. on where you can purchase the bulbs.

Check it out. That's why we pinned it.

Share this post


Link to post
Share on other sites

silvermate,

You seem to be describing the Jim Walker LCD replacement. Have you actually seen the Mikado? Someone stated that the Mikado looks original, but I've never seen it.

Please clarify.

Joe

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this