Jump to content

1999 Es300 Oil Pressure Light Issue


ES_300
 Share

Recommended Posts

I have 99 ES300 with about 111K on the clock. Last year my Oil pressure light came on and I took it to the workshop, where they said it’s the sludge problem so I got it fixed and they replaced the Oil Pump also. Everything seemed to work fine but after 5/6 K miles the light came on again, but when I used to press the Gas pedal it was going away and releasing the gas pedal making it come on again. I checked the owners manual where it said

"It could come ON after a hard stop or if the Oil level is extremely low and if it is constantly ON then take it to dealership but if you accelerate and it goes away then there is nothing serious and there is no particular reason for this light to come on"

So I just took it for Oil change as I already got the oil pump replaced, and after changing the oil the light didn't come on again until yesterday and after about 1100 miles after changing the oil. I am just confused what is going on with it. Can you guys suggest something? Thanks in advance

Link to comment
Share on other sites

I have 99 ES300 with about 111K on the clock. Last year my Oil pressure light came on and I took it to the workshop, where they said it’s the sludge problem so I got it fixed and they replaced the Oil Pump also. Everything seemed to work fine but after 5/6 K miles the light came on again, but when I used to press the Gas pedal it was going away and releasing the gas pedal making it come on again. I checked the owners manual where it said

"It could come ON after a hard stop or if the Oil level is extremely low and if it is constantly ON then take it to dealership but if you accelerate and it goes away then there is nothing serious and there is no particular reason for this light to come on"

So I just took it for Oil change as I already got the oil pump replaced, and after changing the oil the light didn't come on again until yesterday and after about 1100 miles after changing the oil. I am just confused what is going on with it. Can you guys suggest something? Thanks in advance

it is a well known problem with the 1mz-fe v6 engine. Do the oil change more often with the sych oil.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership