Jump to content

Help 98 Es300 Might Be Running Hot


chris_t
 Share

Recommended Posts

Hi all,

Drove home my new for me 98 es300 with 141K from work today (8 miles), and noticed that temp gauge was only 2-3 bars below half way! Also, smelled a strange smell when turning sharply to the right (leaking ps fluid? the car recently got a new ps pump).

Other than that it runs great. Has a few dings, but garage kept so no sun damage in or out. Perfect soft trim and leather looks a car with half as many miles.

PO gave me all his service records, but a little worried nonetheless.

Link to comment
Share on other sites

Was the smell like maple syrup?

By the way, Welcome to the LOC!

Thanks! I am washington, DC btw. No, just kind of a hot almost oily smell. I am freaking out because I'm worried that this thing might need a new head gasket (and I went through that 2x on my previous vehicle, a 95 c280). Only when I turn sharply though.....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership