Jump to content

01 Ls 430 Beep Or Warning Light On Acceleration


opie
 Share

Recommended Posts

I'm getting a beep and a quick flash of a warning light on the dash when I accelerate or turn quickly. The light flashing is red and is central on the dashboard, above the tachometer or maybe speedometer if I recall correctly. It has a "!" (exclamation) symbol.

Does anybody know what this warning light is for?

It only happens if I turn quickly or accelerate quickly.

Link to comment
Share on other sites


It's most likely the traction control or the VSC kicking in. Are you doing these activities in the rain? Every once in a while if I try to pull out suddenly on a wet surface I can light up the traction control.

Are the tires old? Do you feel a reduction in power when the light flashes?

I'm getting a beep and a quick flash of a warning light on the dash when I accelerate or turn quickly. The light flashing is red and is central on the dashboard, above the tachometer or maybe speedometer if I recall correctly. It has a "!" (exclamation) symbol.

Does anybody know what this warning light is for?

It only happens if I turn quickly or accelerate quickly.

Link to comment
Share on other sites

Sounds like brake pad wear indicators if you ask me. If I remember correctly, it looks like this: ((!))

When a excessive brake pad wear is sensed, a "brake wear" message is displayed on the "multi information display" (trip computer) in the instrument cluster of a 98-up LS.

Link to comment
Share on other sites

Sounds like brake pad wear indicators if you ask me. If I remember correctly, it looks like this: ((!))

When a excessive brake pad wear is sensed, a "brake wear" message is displayed on the "multi information display" (trip computer) in the instrument cluster of a 98-up LS.

I looked more closely today. The ! lights up and then in the display below it says the washer fluid is low.

That's simple enough. If the problem isn't resolved by topping up the fluid, I'll post back. Thanks for the responses.

Link to comment
Share on other sites

Sounds like brake pad wear indicators if you ask me. If I remember correctly, it looks like this: ((!))

When a excessive brake pad wear is sensed, a "brake wear" message is displayed on the "multi information display" (trip computer) in the instrument cluster of a 98-up LS.

I looked more closely today. The ! lights up and then in the display below it says the washer fluid is low.

That's simple enough. If the problem isn't resolved by topping up the fluid, I'll post back. Thanks for the responses.

Hahaha.... well I was close I guess....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share



×
×
  • Create New...

Forums


News


Membership