Sign in to follow this  
sweethunnylh

Speaker Problems

Recommended Posts

Hey all, I am having trouble with my speakers in my 1993 SC300. I noticed it after I got back from a trip and started my car, the battery was obviously very run down. While traveling to get a new battery I noticed that my right speakers did not work anymore and my rear speakers did not produce any sound beside bass (I am unsure if they were always like that but I believe they produced sound before). The passenger side speakers began working again after getting back into the car but rear speakers are still not producing anything besides bass. Anyone had this happen before? Any suggestions? I am going to replace the battery tomorrow when it isnt snowing, is it possible that the battery did not have enough juice to power the speakers? (the battery was not able to run the car and handle the load of putting down the windows, this caused it to stall). Thanks!

Share this post


Link to post
Share on other sites

yea it is possible it was all caused by the battery being dead, when my battery went bad about a month ago everytime i turned on my turn signal my stereo shut off and my clock reset, once replacing the battery everything was fixed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this