SKperformance

Tells Us About Your Car And Its Mods Or Problems

Recommended Posts

List your model, year ,

# of owners ,

price when bought and from where

lenght of ownership and attributed problems and repair costs.

Also mention where you had it fixed ( lexus, independent, midas or diy).

When it was done.

Any mods done to the car and its costs.

If desired your age and insurance you pay.

If you have any picutes in the gallery put links in the post so we can have an idea about the car.

Please only post once and if you have a question either pm the member or make a new thread .

This will keep the page from being filled with excess.

Share this post


Link to post
Share on other sites

lexus IS300 2001, bought used 3 weeks ago 67k miles. stock with auto trans. now be warned order zi performance module from ebay for approx $40 after shipping. Installed professionally by myself. I work at a local Dealership and took before and after readings using snap-on vantage scanner. only wires inbetween intake air temp sensor and ecu to basically fool ecu to thinking cooler intake air temps that portion did work reduction approx 40% but caused check engine lamp? not sure if unit failed but got no response from seller! Do not use this gimmick.

just my 2 cents. returned to stock and now looking into a headerkit and down pipe then muffler upgrade but not wanting to get too obnoxiously loud any suggestions? :)

Share this post


Link to post
Share on other sites

Hi I have a 2001 Is300 and right about now im not too happy with it. It has 70,xxx miles on it and its and e-shift. It has some crappy 18's on 40 series falken's. It also has an injen intake and some retarded red painted covers on the engine and arm rests and cupholders. Im the second owner I believe and the cel stays on all the time and blinks when i come to idle or get on it hard. I have had the rims and tires balanced but it shakes a lil bit at 35-40 and up. Its not that big of a deal on smooth roads, but on less than smooth roads its annoying. The codes it is bringing up is multiple misfire codes on like all cylinders and o2 sensor. Also, the driver side headlight periodically decides to go out and stay out for a period of time. It is very inconsistent and hard to diagnose when and why this happens. Are these problems anyone else has faced and where should i start to fix the problems. I took it to the dealer and that was a HUGE waste of 95 dollars as they told me to they were going to do a 60k service and if that didnt fix it than they were just going to start replacing things. Anyways I bought a set of plugs and wires to start with and any other recommendations would be great. I need any help you can give me whether it has to do with the vibrations or the headlight or the cel codes and TRAC OFF light blinking on and off. I want to sell the car and get something that can actually drive in the snow because im moving to michigan. I thought i had problems with other cars driving in the snow; you might as well park the IS when the white stuff comes down because that car is useless in the snow even when im using 225 pirelli snowsports. Anyways thanks for any help you can give me! God Bless You!

Share this post


Link to post
Share on other sites
lexus IS300 2001, bought used 3 weeks ago 67k miles. stock with auto trans.  now be warned order zi performance module from ebay for approx $40 after shipping. Installed professionally by myself. I work at a local Dealership and took before and after readings using snap-on vantage scanner. only wires inbetween intake air temp sensor and ecu to basically fool ecu to thinking cooler intake air temps that portion did work reduction approx 40% but caused check engine lamp? not sure if unit failed but got no response from seller!  Do not use this gimmick.

just my 2 cents. returned to stock and now looking into a headerkit and down pipe then muffler upgrade but not wanting to get too obnoxiously loud any suggestions?  :)

ey when u get new headers and make it a straight pipe ure engine lamp is gonna light up and your traction control wil jsut start blinking and not work the thing u need to do is get an 02 imulator this overides the sensor to making it think all the crazy air is all good cuz car 97 and up are designed to follow the air pollution and when u pass the requirments ure car will default and not perform as well so just get an o2 imulator and itll be all goood

Share this post


Link to post
Share on other sites

Air Intakes are known to throw CEL codes and sometimes TRAC codes out randomly, your car either likes them or it doesn't ... my 01 doesn't so I had to take mine off haha ... I would first of all take off the Injen and try your stock filter setup, reset the computer [by unplugging the battery terminals and replugging them] and see how that goes, it should solve your CEL and TRAC light issues ... as far as the vibrating? The car might have been lowered and re-raised before you bought it? Might have been in an accident? I would get a front end alignment done or a 4 wheel alignment from your dealership, that will prolly run you a good $110 at least ... again, mine does the same thing because after I got my brakes done, the shop I took it to neglected to re-align my suspension. I've also had my wheels and tires (all new by the way) rebalanced a few times so I'm assuming this is my problem ... no biggie ... as far as the headlight goes? hmmm, I would have to say it was possibly in an accident or maybe just faulty wiring .... but dont mess with that stuff yourself [or at least make sure nobody is messing with the headlightswith] because to fire the HID headlights a huge amount of power is needed, 25000 volts I think it is, i could be wrong ... I have never had issues with my 01 IS300, I've kept it properly maintained, it has 106,500 miles on it and still kicks serious !Removed! when people try to race me :) ... the only thing ive EVER had a problem with is my CD player dying, I'm on my 2nd one and the sunroof motor went out ... recently had the timing belt and drive belt and crank seal changed at my local dealership and that run me about $650 but well worth it. Good luck with the car and enjoy!

Hi I have a 2001 Is300 and right about now im not too happy with it. It has 70,xxx miles on it and its and e-shift. It has some crappy 18's on 40 series falken's. It also has an injen intake and some retarded red painted covers on the engine and arm rests and cupholders. Im the second owner I believe and the cel stays on all the time and blinks when i come to idle or get on it hard. I have had the rims and tires balanced but it shakes a lil bit at 35-40 and up. Its not that big of a deal on smooth roads, but on less than smooth roads its annoying. The codes it is bringing up is multiple misfire codes on like all cylinders and o2 sensor. Also, the driver side headlight periodically decides to go out and stay out for a period of time. It is very inconsistent and hard to diagnose when and why this happens. Are these problems anyone else has faced and where should i start to fix the problems. I took it to the dealer and that was a HUGE waste of 95 dollars as they told me to they were going to do a 60k service and if that didnt fix it than they were just going to start replacing things. Anyways I bought a set of plugs and wires to start with and any other recommendations would be great. I need any help you can give me whether it has to do with the vibrations or the headlight or the cel codes and TRAC OFF light blinking on and off. I want to sell the car and get something that can actually drive in the snow because im moving to michigan. I thought i had problems with other cars driving in the snow; you might as well park the IS when the white stuff comes down because that car is useless in the snow even when im using 225 pirelli snowsports. Anyways thanks for any help you can give me! God Bless You!

Share this post


Link to post
Share on other sites

Hey hows it going guys

My 06 IS350 came in 2 1/2 weeks ago, i noticed when I turn it on after it warms up whether its in P R N or D it has a ticking sound in the engine, a few days later i took it a lexus dealership closer to my house ( there was also a grinding sound when i turn the wheel all the way to the right) i told them about the engine and the grinding sound, they took it in and gave me a loaner and called me back 3 hours later and told me the the grinding sound is the wheel is wide and its rubbing against the rubber guard above it, and they told me the engine sound is normal. so a few days alter my spoiler came in and i took it to the dealer where i bought it from and told him the same thing.... he gave me the same results. WTF???? :wacko: that sound is not normal and even my friends agree. what i plann on doing is going back to the dealership and tell them to turn on an IS350 and we will compare, the car should be purring, not ticking. any input or advice, or has anyone expierenced this porblem? Other than those little things the car is excellent really fast and really smooth. :D

thanks guys

-omad

Share this post


Link to post
Share on other sites

Hey hows it going guys

My 06 IS350 came in 2 1/2 weeks ago, i noticed when I turn it on after it warms up whether its in P R N or D it has a ticking sound in the engine, a few days later i took it a lexus dealership closer to my house ( there was also a grinding sound when i turn the wheel all the way to the right) i told them about the engine and the grinding sound, they took it in and gave me a loaner and called me back 3 hours later and told me the the grinding sound is the wheel is wide and its rubbing against the rubber guard above it, and they told me the engine sound is normal. so a few days alter my spoiler came in and i took it to the dealer where i bought it from and told him the same thing.... he gave me the same results. WTF????:wacko: that sound is not normal and even my friends agree. what i plann on doing is going back to the dealership and tell them to turn on an IS350 and we will compare, the car should be purring, not ticking. any input or advice, or has anyone expierenced this porblem? Other than those little things the car is excellent really fast and really smooth. :D

thanks guys

-omad

People have been discussing that problem here:

Ticking sound

Share this post


Link to post
Share on other sites

Hey hows it going guys

My 06 IS350 came in 2 1/2 weeks ago, i noticed when I turn it on after it warms up whether its in P R N or D it has a ticking sound in the engine, a few days later i took it a lexus dealership closer to my house ( there was also a grinding sound when i turn the wheel all the way to the right) i told them about the engine and the grinding sound, they took it in and gave me a loaner and called me back 3 hours later and told me the the grinding sound is the wheel is wide and its rubbing against the rubber guard above it, and they told me the engine sound is normal. so a few days alter my spoiler came in and i took it to the dealer where i bought it from and told him the same thing.... he gave me the same results. WTF????:wacko: that sound is not normal and even my friends agree. what i plann on doing is going back to the dealership and tell them to turn on an IS350 and we will compare, the car should be purring, not ticking. any input or advice, or has anyone expierenced this porblem? Other than those little things the car is excellent really fast and really smooth. :D

thanks guys

-omad

My 06 IS350 don't have the ticking sound. But when I turn left. I will hear a very low grinding sound too. And grinding when I break.

Share this post


Link to post
Share on other sites

Hi, Regarding problem with Mirror- I have a 2006 is350,white with nav. Lots of power, and I am now dependent on the navigation, how fun. I love the car and am very happy with it except for one irritation. My inside rearview mirror automatically darks at night and makes other car headlights so dark I can hardly drive the car at night. I brought it into the dealer and they advise me there is no way to adjust the darkness. I have been advised to leave it over night so they can see what it does themselves. Has anyone experienced this? And any solutions for this problem.

Any suggestions would be welcome.

Thediamondfairy

Share this post


Link to post
Share on other sites

Hey, diamond. I've not experienced the mirror darkening too much" thing, but I have noticed that it darkens when I'm on a bright street, with a lot of street lights. It doesn't create a problem, I just thought it was a little too dark.

Regarding the injectors, that is definitely the direct injection. I run an auto repair shop and when the direct injection came out on other models, everyone used to bring their cars in with a "valve lifter" noise...Problem is, THERE ARE NO VALVE LIFTERS.

The injectors tick, you'll have to get used to it. BUt hey, with 306 hp and low emissions, who can complain???

Share this post


Link to post
Share on other sites

I have a Black 2006 IS350 that I just purchased new 2 weeks ago. Has anyone had trouble with the paint/clear coat ? I had a bird drop on my car it could not have been on there more than an hour before I found it and cleaned it off but it had already etched the paint. Today I found another spot much larger where something like a bird dropping etched into the paint again. I have also found it scratches very very easily. I have owned 5 black cars in the past and never had a problem with the clear coat/paint of a car scratching so easy or bird or enviromental factors causing such problems. The last Lexus I owned was a Red 2004 IS300 and never had these problems. The paint and clear coat was much better and more forgiving. I have waxed this car 3 times with Meguires NXT and did the Meguires polish in between but it seems the clear coat is too soft and or thin to protect the paint .

Richard

Share this post


Link to post
Share on other sites

To answer the questions which started this post:

I have a 2004 Is 300 manual. Things that have broken: the CPU. No kidding. 80 mph on the interstate and the dashboard lit up like a xmas tree. Dealer fixed that under warranty.

Autoleveling broke on one of my headlights. Dealer fixed that as well.

Other than that, the usual gripes about crappy paint.

Well worth the money I paid. I will have a hard time giving this car up. Interested in mods to improve performance, hp and torque gains more than anything. The SRT intake looks intriguing, but their claimed numbers look bogus.

Share this post


Link to post
Share on other sites

This is GIOVANNA"S new IS350 silver tanabe exhaust and 1.5 drop springs, Gianelle wheels staggered 20-8.5 frt and 20- 10 on rear. 2 rockford amps 2 12's Rockford woofers 4 seperates and 15" monitor in hatch.....

more to come.....

post-30702-1162861971_thumb.jpg

Share this post


Link to post
Share on other sites

2006 IS250 RWD MT6

Silver

Purchased Nov 6th, 2006 used.

At time of purchase had 14,000 miles on it. Someone defaulted on a lease.

Paid $27,900 for it. Very basic car, Vented seats and floor mats.

Bought at a new car dealer - not Lexus.

Only problem was that my headlights stayed on one day at work. Got out at the end of the day, engine was dead. Jump started the car, but :censored: :cries: :blushing: hooked up the battery cables backwards. After I changed them, the car seems to run fine, but the windows won't go up or down. I'm checking the fuses on the windows today. Wonder what else I screwed up.

LOVE THE CAR - my second Lexus, my third Toyota product, last two cars, over 200k miles each. Expecting the same from this baby.

larry

Share this post


Link to post
Share on other sites

You have to reprogram the windows. Run each window down and up with it's own door switch. Then they should all work with the drivers switch.

Share this post


Link to post
Share on other sites

You have to reprogram the windows. Run each window down and up with it's own door switch. Then they should all work with the drivers switch.

Bartkat:

Appreciate the advice, but the only window that works is the drivers window. The other windows don't work at all, either from the driver's door, or from their own door. I think that I might have blown the fuses for each of the window motors with my stupid human trick (jumpstarting backwards).

Where do I find a fuse puller that will grab those fuses? The standard american fuse pullers are just too big to grab the small fuses in the Lexus passenger fuse boxes. Is there one located in one of the other fuse boxes?

larry

Share this post


Link to post
Share on other sites

There should be a fuse puller in the main fuse box under the hood.

Thanks, I'll check it out tonight.

larry

Bartkat -- you're the man. I tried it this morning after I read your post, and nothing worked. But then I got back to my office, and realized that I probably had the window lock on. Tonight, I got home, and parked the car. Put the window lock OFF and then went to each door. The switch was flashing, and each window went all the way down and then back up. As I closed each door, the car beeped three times. And as a check, I climbed back into the drivers seat, and the automatics worked perfectly again.

I guess that I did no damage. Thanks so much. I love this car, and I've only had it two weeks.

larry

Share this post


Link to post
Share on other sites

DOES ANYONE know if they are coming out with any TURBO's for the is 250 2007 model please tell me if u know :)

Share this post


Link to post
Share on other sites

just traded in my 95 es300 on an 03 is300 and so far i love it. tight suspension and new rubber all around make handling a lot better than the es. voice nav (not that i will ever use it) and a decent stereo. afaik i am the second owner. it only has 24k miles and looks great. i paid ~25K and my insurance only went up $20/mo.

pics

42vdfuv.jpg

2jbjwbm.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...