Do Not Sell My Personal Information Jump to content

Sc400 Maf And Engine Surging In Park Or Neutral


Recommended Posts

:chairshot:

Hello guys, I could really use a little help on this one. My SC400 92 started running really bad after cleaning the engine. I now not to do that again, but here is whats happen, the engine runs very sluggish when accelerating and idles at 1000-2000 rpm thats about 35-45 mph. When I come to a stop the car jolts forward revving the engine at 1000-2000 rpm. Also when I put it park or neutral it sounds as if I am pressing the gas with the engine surging up and down. I have replaced the MAF twice with used parts and continue to have the same problem. Have any of you experienced and or resolved this issue.

Link to post
Share on other sites

Hey guys, its been a few days now and no one has replied to my post. I could really use your help is there any one out there that has experienced this problem.

I had my mechanic look this error up in the online tech system called IDENTIFIX.COM and found that certified techs are saying this is a problem with the Idle Air Control Valve. Here's the catch, the parts cost is $650 - $726, that is outrageous for this small part. Anyone know were I can find an after market part or a used one?

post-81871-1225334520_thumb.jpg

Link to post
Share on other sites

Try doing this first. Leave your car running idle for about 20minutes, if you're not getting the correct throttle pressure-right now.

How's your fuel pressure?

Link to post
Share on other sites

I have allowed the car to run for over 20 mins, but continue to get surging RPM. Actually when the car is cold it idles higher than normal about 1800 RPM then once the car warms up it tries to idle down then begins to surge at 1100-1700 RPM. It would really be nice to actually replace the correct part since parts for this vehicle can be be very expensive.

Thanks

Link to post
Share on other sites

Eureka! I have solved the problem, after cleaning my Idle Air Control Valve the car idled down and is purring like a kitten. Here are the details of what was done to fix the engine surge problem. After several days of research I was able to narrow down the potential problem parts. If your engine is idling high between 1000-2000 RPM these are the potential parts that must be tested for errors: the (MAF) Mass Air Flow Sensor, (IAC) Idle Air Control Valve, or Throttle Position Sensor. I recommend you purchase the Original Lexus Repair Manuals for further troubleshooting; there are 3 volumes well worth their weight in gold.

OK, let's get to it...

First and easiest part to test the MAF; see the attached MAF manual.

If test fails replace MAF. Don't not use cleaners; they will make the car run worse. If the problem continues put the original MAF back in and go to next test. Hold on to the replace MAF just in case multiple parts are bad.

post-81871-1225509070_thumb.jpg post-81871-1225509098_thumb.jpg

Second, to test the IAC see the attached IAC manual

If test fails try opening and cleaning ICA. The plastic housing contains and servo motor that can get corroded. Pay very close attention to the position spacer ring at the bottom of the IAC. It must be put back in on it back with the three wing pointed up. Clean and oil the motor with a small wire brush and 180 grit sand paper on gasket areas. Be careful not to use too much oil.

If cleaning fails replace IAC

post-81871-1225510364_thumb.jpg post-81871-1225510382_thumb.jpgpost-81871-1225510420_thumb.jpg

post-81871-1225511466_thumb.jpg post-81871-1225511494_thumb.jpg post-81871-1225511528_thumb.jpg

Third, test Throttle Position Sensor

To test the TPS see the attached TPS manual

If test fails replace TPS

post-81871-1225511781_thumb.jpg post-81871-1225511797_thumb.jpg post-81871-1225511814_thumb.jpg post-81871-1225511833_thumb.jpg

Thanks and good luck!

Link to post
Share on other sites

I have allowed the car to run for over 20 mins, but continue to get surging RPM. Actually when the car is cold it idles higher than normal about 1800 RPM then once the car warms up it tries to idle down then begins to surge at 1100-1700 RPM. It would really be nice to actually replace the correct part since parts for this vehicle can be be very expensive.

Thanks

wow man this is perfect timing my car is doing the same thing once it's warmed up idle surge from 1000-2000 where can i get a repair manual?? thx

Link to post
Share on other sites
nice job.

Thanks for the Pics. I'm sure it will come handy to someone.

I just had my 300 in shop and I will be replacing idle control valve. $700 ouch! They also want to clean fuel injectors for $150/ Is that normal? Car has 155.550 miles and runs great. They are master toyota lexus tech's.

Link to post
Share on other sites
nice job.

Thanks for the Pics. I'm sure it will come handy to someone.

I just had my 300 in shop and I will be replacing idle control valve. $700 ouch! They also want to clean fuel injectors for $150/ Is that normal? Car has 155.550 miles and runs great. They are master toyota lexus tech's.

===================================================

Twodmax, run you are about to get jacked. If you or a friend are some what handy you can clean this unit and save yourself $850. Read through my docs, you will find all you need to do this fix. Follow the test procedures to determine which part is bad. My Lex has 240,000 miles so this car just keeps going and going with the proper maintenance.

Link to post
Share on other sites
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...