Do Not Sell My Personal Information Jump to content

Heating System Sc300


gkalispell
 Share

Recommended Posts

My300 has an operating climate control head, at least it goes to hot on the screen. The air condition portion works fine but I can not get any heat out of it at all. The fluid tank is full to the full make. Is there a fuse or electronic feature that needs to be checked or any other system that I am missing?

Link to comment
Share on other sites

There is an electronic valve that restricts hot water flow to the heater core. It is inline with the hoses going to the heater core. That could be bad or stuck.

Or, it could be that the heater core is clogged and not allowing fluid flow.

Also, the blend door under the dash may not be opening to allow hot air to flow into the cabin.

Tom

Link to comment
Share on other sites

  • 1 month later...
My300 has an operating climate control head, at least it goes to hot on the screen. The air condition portion works fine but I can not get any heat out of it at all. The fluid tank is full to the full make. Is there a fuse or electronic feature that needs to be checked or any other system that I am missing?

any luck on diagnosing and or fixing the problem...i have the exact same issue with my 93 sc300 and am trying to get any help possible.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership