Do Not Sell My Personal Information Jump to content

Lx470 Power Steering


seehack
 Share

Recommended Posts


Today my 99 LX470 suddenly has no power steering. It makes a lot of noise when I turn the wheels. Seems like more effort turning right..... Something is against me turning right. Any idea?

Check if the serp belt is loose/slipping or if there's sufficient fluid in the PS resevoir. Also, when the fluid gets old (black, should be red), it may make some noise. Use dextron II or III ATF only, DO NOT USE PS FLUID IN THE PS RESEVOIR unless you like leaks!

Link to comment
Share on other sites

Today my 99 LX470 suddenly has no power steering. It makes a lot of noise when I turn the wheels. Seems like more effort turning right..... Something is against me turning right. Any idea?

Check if the serp belt is loose/slipping or if there's sufficient fluid in the PS resevoir. Also, when the fluid gets old (black, should be red), it may make some noise. Use dextron II or III ATF only, DO NOT USE PS FLUID IN THE PS RESEVOIR unless you like leaks!

Thanks for the quick response. I did check the PS Fluid level is between Min-Max. Color from outside looks black but will open up to check tomorrow. Its more than noise.... no power assist i.e. takes a lot to turn the wheel... something is resisting it from turning. Where is the Serp belt? It was changed about 1 year/10kmiles ago during the timing belt change.

Link to comment
Share on other sites

Today my 99 LX470 suddenly has no power steering. It makes a lot of noise when I turn the wheels. Seems like more effort turning right..... Something is against me turning right. Any idea?

Check if the serp belt is loose/slipping or if there's sufficient fluid in the PS resevoir. Also, when the fluid gets old (black, should be red), it may make some noise. Use dextron II or III ATF only, DO NOT USE PS FLUID IN THE PS RESEVOIR unless you like leaks!

Thanks for the quick response. I did check the PS Fluid level is between Min-Max. Color from outside looks black but will open up to check tomorrow. Its more than noise.... no power assist i.e. takes a lot to turn the wheel... something is resisting it from turning. Where is the Serp belt? It was changed about 1 year/10kmiles ago during the timing belt change.

Jim,

Just to update. Morning check fluid OK, belts present and seems OK but engine area making cranking sound. Sound to mechanic. After a few miles, red battery/alternator came on. Finally got to independent shop, belt not there anymore. Came loose. Diagnosis shows nut holding the tensioner came loose so belt came off. Alternator OK but Power Steering Pump dead. Why nut came loose? Lexus did not torque it correctly when changed all belts and tensioners as part of comprehensive timing belt service?

Thanks for your input and best regards,

Seehack

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership