Do Not Sell My Personal Information Jump to content

Could Gps System Kill My Battery


Recommended Posts

I have an aftermarket GPS system that is in my 1998 GS 400. For some reason something is draining the battery. I had the alternator checked and they said it was fine. Do you think that it could be the GPS system that was installed in my car.

Thanks Cherika

Link to comment
Share on other sites

its possible. but if you had a reputable shop not likely. did this just start after you had the gps installed? man tracing electrical drains sucks.........if you DIY it can take forever and if you pay for it, it can get very expensive as its so timely. i would take it back to the place that installed your gps. tell them your having a electrical drain (if it just started after u put in the gps, tell them that) and see what they are willing to do to help. good luck and welcome to the forum

brian

Link to comment
Share on other sites

Hi the GPS system was installed by the owner at the lot that I bought the car from. It was installed in late may early june. However I never had this problem before, until one day a friend of mine came into town, and I didnt drive my car for 4 days it was parked. So the 3rd day I tried statring the car and it acted like it didnt want to start. So the man at the battery shop said that something is draining my battery, when the car is not running. I asked the owner at the car lot he said that he had deactivated the system, when I know he could not have deactivated it because he never had access to the car to deactivate the system.

Link to comment
Share on other sites

if u know a stereo shop u trust, i would take it to them and just go over what you said and see what it does. i had a aftermarket alarm (viper) and auto starter on my old es300 for like 4 years and i had a little battery drain and every now and then car wouldn't act right. i couldn't ever pin point the drain but when my dad bought the car from me, the stealer ship convinced him that was it and charged him like 350 to unhook it (yeah i know i couldn't talk him outta let THEM do it)

brian

Link to comment
Share on other sites

Hi the GPS system was installed by the owner at the lot that I bought the car from. It was installed in late may early june. However I never had this problem before, until one day a friend of mine came into town, and I didnt drive my car for 4 days it was parked. So the 3rd day I tried statring the car and it acted like it didnt want to start. So the man at the battery shop said that something is draining my battery, when the car is not running. I asked the owner at the car lot he said that he had deactivated the system, when I know he could not have deactivated it because he never had access to the car to deactivate the system.

If you didnt drive it in 4 days thats prob the prob. I have to go out and crank up mine every 5 days or so or I,ll have to jump it.

Link to comment
Share on other sites


If you didnt drive it in 4 days thats prob the prob. I have to go out and crank up mine every 5 days or so or I,ll have to jump it.

no way. i can and have let mine sit for over a week on several occasions and had no problems. i have a optima yellow top too though but still that shouldn't be the prob

brian

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership