Do Not Sell My Personal Information Jump to content

How To Run Amp Wires To Battery?


is300_519
 Share

Recommended Posts

Hey everyone,

I am a proud new owner of a 04 IS300 and loving it!

Just put a AVIC-D3 unit in and now would like to add my sub and amp to complete the sound I am longing for.

Any information that could help me run the wires from my amp to the battery would be appreciated.

Thanks in advance

Link to comment
Share on other sites


I have a used install kit if you need.

I used V8 post clamp and inline fuse. Then ran it along the firewall just under the windshield line and covered it with black leech. Then ran the power line thru the same hole most of the other cables and wires go in, I just made the opening a little larger in the rubber gromet they originally used from the factory. Then I slid the wires behind the console next to the gas pedal, and ran the power feed under the carpet all the way back to the trunk where I mounted the 2 Alpine Vpower amps on the back seat wall. You'll need to remove the passenger seat, and the back seat so you can run all the wires cleanly and make sure you don't have any kinks or cut areas.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership