Do Not Sell My Personal Information Jump to content

Need Help With Navigation


5power
 Share

Recommended Posts

I just recently purchased a 2002 sc430 and today I went to start the car and the Navigation screen will not open at all. I checked all the fuse under the dash and in the engine compartment and no luck. All fuses were fine. I also found that my audio cover does not work also when you hit the button. Any suggestions on trouble shooting would be helpful before I take the dive and go to the stealership lol, Thanks

Link to comment
Share on other sites

  • 4 years later...

I know it has been 5 years since your post, but the 2002 I recently bought had the same problem, and periodically still does. I found out about the door in fact because one day it magically closed. I was playing with one of those sticky pads that hold your cell phone in place and pressed against the button. I did not know what the button was for though,

Turns out that the button sticks under the cover. If I press the cover on either side of the button, or used the sticky pad to retract the button, it moves the door. I have tried to clean the button with electronics parts cleaner, but am not sure if it works. So, that may be part of the problem you are having, I don't know. If anyone has any ideas on how to make this button more reliable, please let me know!

Link to comment
Share on other sites

  • 2 years later...

Chris - I realize it has been years since you posted about this, but I have this same issue with the navigation door on my 2002 SC430. It just suddenly stopped closing for no apparent reason. I did NOT understand what button you are referring to in your post!! If there is any way you can guide me, I would appreciate it. - Thank you!

Link to comment
Share on other sites

Two things come to mind when I read both your issues. First is, as noted above, that the button is sticking and not allowing solid contact with the underlying electronics. Secondly, the door has a common problem of coming off the track. Check both of these issues and let us know. I will search for a fix for the track repair, if that turns out to be your problem. Let me know. good luck.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership