Do Not Sell My Personal Information Jump to content

Tailight Warning Light On!


myko
 Share

Recommended Posts

Hey..This is my first post and would just like to say hi to all and thanks in advance for your knowledge.

Here's what's up with my car.

Those round brake light/ tailights next to the license plate are acting up. I had the stock bulbs in there for many years. I recently replaced them with LEDS. After doing so, I saw a tailight warning come on on the dash..The lights worked so I kinda of ignored the light for a bit..

Getting annoyed with the warning light, I decide to put back the stock bulbs to eliminate the warning light issue. Nothing happened..The warning light is still there and now I notice brake lights are not illuminted while the lights are on. They only come one when I hit the brakes.

I also noticed as soon as I turn the parking lights on, that brake warning light shows up again..

Any ideas? Are the bulbs bad? I'm a little confused to be honest. All of the other lights are working fine as well..

P.s. I checked the fuses and everything looks ok.

Link to comment
Share on other sites


The LEDS probably had a different resistance rating.. other than that...idk. Check the hi-mount stop light to see if its still working.

Hey..This is my first post and would just like to say hi to all and thanks in advance for your knowledge.

Here's what's up with my car.

Those round brake light/ tailights next to the license plate are acting up. I had the stock bulbs in there for many years. I recently replaced them with LEDS. After doing so, I saw a tailight warning come on on the dash..The lights worked so I kinda of ignored the light for a bit..

Getting annoyed with the warning light, I decide to put back the stock bulbs to eliminate the warning light issue. Nothing happened..The warning light is still there and now I notice brake lights are not illuminted while the lights are on. They only come one when I hit the brakes.

I also noticed as soon as I turn the parking lights on, that brake warning light shows up again..

Any ideas? Are the bulbs bad? I'm a little confused to be honest. All of the other lights are working fine as well..

P.s. I checked the fuses and everything looks ok.

Link to comment
Share on other sites

The LEDs pull less, a lot less, so the light in the dash comes on. You can spend money and install resistors, or do what I did, remove the warning light from the dash. Takes about 30 min and there are detailed instructions on removing the cluster in here somewhere.

As far as the originals you installed, were they bad to begin with? In otherwords, there is a large filament inside the bulb for the brake lights, and a smaller one for the lower wattage "clearance" lights when the headlights are on. Sounds like you have just one filiamet working that only lights when you apply the brake.

This site might have the resistor you need/ new bulbs.

http://autolumination.com/1156_1157.htm

click on: LED Flashers, Protectors, Load Equalizers Turn Signal Fix

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership