Do Not Sell My Personal Information Jump to content

Ac Light Blinking


newtekdb
 Share

Recommended Posts

I have an 1995 LS400. Recently when I went to go to start the car, when I hear this grunting sound when the AC kicks in. I also notice the AC button starts flashing, then I don't get any cooling. Is this a problem with a relay, low coolant or God forbid my compressor?

Link to comment
Share on other sites

I have an 1995 LS400. Recently when I went to go to start the car, when I hear this grunting sound when the AC kicks in. I also notice the AC button starts flashing, then I don't get any cooling. Is this a problem with a relay, low coolant or God forbid my compressor?

Ditto on my 1992 LS400 (still freon) - I recently had it charged also. then noticed a drop off in cooling, then same as above. I put a guage on low pressure side and found 40psi with compressor off, then ZERO when turning on compressor - along with grunting...

Link to comment
Share on other sites

High and low side pressure will tend to equalize with unit off after 5 minutes or so. All that says is that your system is not completely open to atmosphere. You need to check low side with compressor running. It should be in the 25-35psi range for cooling to occur.

Sounds like:

1 moisture/air in system. Google: Dry-Pak and Cryo-Silane. Have your tech purchase both and install them. You need an EPA 609 cert. to buy yourself.

moisture is deadly to any ac system.

2 leak in system - google: cliplight to seal it.

Link to comment
Share on other sites

High and low side pressure will tend to equalize with unit off after 5 minutes or so. All that says is that your system is not completely open to atmosphere. You need to check low side with compressor running. It should be in the 25-35psi range for cooling to occur.

Sounds like:

1 moisture/air in system. Google: Dry-Pak and Cryo-Silane. Have your tech purchase both and install them. You need an EPA 609 cert. to buy yourself.

moisture is deadly to any ac system.

2 leak in system - google: cliplight to seal it.

Same problem occured in my car too. I took to mechanic twice. Both had opinion with problem in controller. As per them the compressor clutch does not activate and ultimately cooling is not possible. May be this is common problem in Lexus vehicle.

Somebody can help us to solve it. :rolleyes:

Link to comment
Share on other sites

I have an 1995 LS400. Recently when I went to go to start the car, when I hear this grunting sound when the AC kicks in. I also notice the AC button starts flashing, then I don't get any cooling. Is this a problem with a relay, low coolant or God forbid my compressor?

Low refrigerant will cause the compressor to go into 'save itself' mode. The refrigerant is what carries oil to the compressor. Not enough refrigerant =Not enough oil= burnt compressor.

Find the leak, repair it, and recharge.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership