Do Not Sell My Personal Information Jump to content

Sat Radio And Then No Start


Recommended Posts

Had the car for 31K. Sat Radio worked this am. Get in the car this afternoon. No audio on XM - but display shows songs. FM, AM and CD works. Decide to restart car...see if that will "re-boot.", the cure all for cell phone and computer problems... Turn car off. Then go to restart and it just turns over - doesn't start. Try again it starts and now XM does work. Anyone have anything similiar happen?

Link to comment
Share on other sites


"No audio on XM - but display shows songs."

I get the reverse every 20 starts or so in my Porsche. Radio plays last station it was on, but no display and can't change station. No problem starting car ever, though. Cures itself after a couple of engine restarts.

Dealer says XM Sat unit is on a fiber optic bus, but cannot diagnose it even with their computer. Could be a kinked fiber cable that also goes through the ignition switch.

In your case, could be just a bad copper wire connection. You could start by checking the power and ground to the Sat unit, especially if you are using switched power.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership