Do Not Sell My Personal Information Jump to content

Catalytic Efficiency


JLowell
 Share

Recommended Posts

I just bought a super clean 1997 LS 400 with 126,000 miles. It looks like new and the owner had all the service records, etc. The original owner had the engine steam cleaned just before selling it and already had to replace a part on the ignition that the shop told him shorted because of the steam cleaning. Now I have a check engine light and my code reader is telling me it's "catalytic efficiency on 4 banks." I'm now to the code reader and the V-8, but I can't believe that I would have catalytic converter trouble on both exhausts simultanously. Also, I've had three other Toyota to over 200,000 miles and they never had exhaust problems. Anyone every see this type of problem? My only guesses are that it might have something to do with the injector cleaner that the shop put in - again just before it was sold. I got the impression that the original owner wanted everything fixed before he sold it.

Link to comment
Share on other sites

  • 5 months later...
I just bought a super clean 1997 LS 400 with 126,000 miles. It looks like new and the owner had all the service records, etc. The original owner had the engine steam cleaned just before selling it and already had to replace a part on the ignition that the shop told him shorted because of the steam cleaning. Now I have a check engine light and my code reader is telling me it's "catalytic efficiency on 4 banks." I'm now to the code reader and the V-8, but I can't believe that I would have catalytic converter trouble on both exhausts simultanously. Also, I've had three other Toyota to over 200,000 miles and they never had exhaust problems. Anyone every see this type of problem? My only guesses are that it might have something to do with the injector cleaner that the shop put in - again just before it was sold. I got the impression that the original owner wanted everything fixed before he sold it.

I feel your pain. Just bought a 95 LS 400 with 259K. 6 hours after I made the purchase the check engine light came on. The dealer said it was the cat's. Think I'll try some of the recommendations about WOT and the seafoam treatment thing. Good luck.

Link to comment
Share on other sites

Just because you have a cat code doesn't mean it's the cats. The cats could be overwhelmed by an ignition or fuel system fault. A bad coil affects both banks, but won't pop a code. A bad injector won't pop a code. Keep diagnosing, I'll bet it isn't the cats.

Remember that lots of folks replace O2 sensors because they seem stuck at a high or low value. That proves they are WORKING, and that the fault is upstream.

Link to comment
Share on other sites

Hi, my 97 LS has 226K on it had has no cat problem, and my 94 LS has 252K on it without cat problems, so look for a reason/problem up on the engine to be causing the failure..

I just bought a super clean 1997 LS 400 with 126,000 miles. It looks like new and the owner had all the service records, etc. The original owner had the engine steam cleaned just before selling it and already had to replace a part on the ignition that the shop told him shorted because of the steam cleaning. Now I have a check engine light and my code reader is telling me it's "catalytic efficiency on 4 banks." I'm now to the code reader and the V-8, but I can't believe that I would have catalytic converter trouble on both exhausts simultanously. Also, I've had three other Toyota to over 200,000 miles and they never had exhaust problems. Anyone every see this type of problem? My only guesses are that it might have something to do with the injector cleaner that the shop put in - again just before it was sold. I got the impression that the original owner wanted everything fixed before he sold it.

post-5365-1223435393_thumb.jpg

post-5365-1223435441_thumb.jpg

Link to comment
Share on other sites

My '95 used to randomly throw a P0420/P0430 (maybe 4-5 times over the 4 years/90k miles I had it). I would clear the code and it would go away for a while. I just considered it a "quirk" since I was getting excellent fuel mileage and performance.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership