Do Not Sell My Personal Information Jump to content

Gauge Cluser Problem!


91-LS_400
 Share

Recommended Posts

I had my gauge cluster rebuilt by bba remanufacturing. they said that nothing was wrong with it but that they would double check. they sent it back and i put it in and i still have no lights turning on or ne thing. WHAT the hek is going on? its really frustrating. i just spent 200 buks on nothing and i still have the problem. CFuses are good so i donno what to do :(

Link to comment
Share on other sites

The only thing I can think of is that when I reinstalled my cluster after having it reworked by Jim Walker, I noticed that the electrical connectors were kinda' loose upon reinstallation. I think because it was a royal pain to disconnect the plug ins on removal, they become loose upon reinstallation, since I had broken the original connection. My first try at reinstalling the cluster scared me to death, too-almost nothing showed on the cluster. I had to remove the whole thing again, check the plug ins, and reinstall securely. All has been fine ever since. Hope this is your problem.

Link to comment
Share on other sites

If your cluster is good(if), and our fuse is good, than you have wiring between your fuse and cluster being the only carrier of electricity. The wire is possibly broken or correded, but more than likely, as TexasLexus said, it is a connector issue at one end. Grab a multimeter and check your continuity on the wire and on the connector to the wire, and make sure it all seems good.

Best of Luck!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership