Do Not Sell My Personal Information Jump to content

Left Headlamps Turned Off After 2-5 Minutes


bluethunder2008
 Share

Recommended Posts

Hi, I have LS98 (Halogen , the white blue color light), and it works fine with me, those days I started to get this issue,

the left headlamp turns off after 2-5 minutes while I'm driving.

Does that mean I need to change the lamp only ? or there is something wrong in the wiring ?

I need your suggestion.

Link to comment
Share on other sites

i got this same problem which was the bad headlight plug. the plug gets hot after a while and cause contact problem. cleaning it wont solve the issue long, you may need to replace the plug. I did replace it few months ago and the issue never comes back

Link to comment
Share on other sites

  • 2 weeks later...

I found the cause of this problem...

The lamp switch in the steering does not work correctly, yesterday I pressed it little hard and the lamps stayed on the hole trip, then today I tried to play with it, it seems like a lose inside it. like the sound tick tick..

I think I need to find a replacement for it...

Hi, I have LS98 (Halogen , the white blue color light), and it works fine with me, those days I started to get this issue,

the left headlamp turns off after 2-5 minutes while I'm driving.

Does that mean I need to change the lamp only ? or there is something wrong in the wiring ?

I need your suggestion.

Link to comment
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership