Do Not Sell My Personal Information Jump to content

Stereo/speaker Problem 2001 Lx470


vetteman
 Share

Recommended Posts

About 6 weeks ago, I noticed one of the rear speakers quit working. Did nothing.

About 5 days ago, while driving, stereo completely cuts out for a about 10 seconds then comes back on.

Yesterday, while driving, stereo completely went out with total silence. Then, about 10 minutes later, extremely loud and disturbing noise comes through the speakers for a few seconds then goes quit again.

2001 LX 470 with the upgraded factory speakers.

Consumer Reports listed stereo as being the only bad area with this otherwise highly recommended vehicle.

Do I fix existing which may break again or buy after market?

Any and all ideas appreciated

Link to comment
Share on other sites

  • 4 months later...

Greetings from Greenland :)

I had a similar problem on my 2001 LX with ML sound system. I solved the problem when I replaced the ML amplifier with an upgraded ML amplifier B) ... if you choose to replace the amplifier with same part number, you will risk same problem after some use :o . - good luck :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Forums


News


Membership